Pi cam v2 on Rasperry Pi 4 not working at 720p or 1080p

Hi,

I have pi 4 and pi cam v2. Video streaming only works if I select the lowest possible resolution in the Astroprint settings (cloud version). If I select 720p or 1080p I doesn’t work.

If I select HD 1080p I get the message my pi cam does not support this resolution (which is weird since the pi cam can stream at 1080p in Octoprint if I’m correct).

If I select HD 720p I can only take picture but not start a video stream.

Note : Can Astroprint stream in 1080p if I use a USB cam like the Logitech c920 ?

1 Like

Thanks @Michel-Alexandre_Des for the detailed question :slight_smile:

The camera might support 1080p (I’m pretty sure it does) but it doesn’t advertise itself in the v4l2 driver as doing so, in at least a way we can read it. So for our software it cant only go to 720p.

The video could be another problem. Could you please share a screenshot of the screen you get when trying to play video at 720p?

We have the c920 streaming at 1080p without problem in our lab. However it’s an expensive camera and I would’t want you to spend money to realize that it doesn’t work for you. Let’s figure out your raspicam problem first.

Here’s the relevant part of whatv4l2-ctl --list-formats-ext shows for a raspicam v2 connected to a RPi 3B:

[4]: 'H264' (H.264, compressed)
Size: Stepwise 32x32 - 3280x2464 with step 2/2

Though notably, it does allow me to choose 720p, which does work. But when I attempt to change the setting to 1080p it shows an error claiming that the camera doesn’t support the resolution.

It’s definitely not a problem with v4l2.

This same issue has been reported at least two times previously:

Astroprint does not support the Raspberry Pi cam what ever they want to make us believe. The Pi cam only works at very low 480p resolution with Astroprint and that’s not what supporting a device is. After dealing with my Astrobox/Astrprint tech support for days I’ve finally decided to flash everything and go with Octopi/Octoprint. After a single afternoon everything was setup working flawlessly and my Pi cam was fully functional! I’ve installed Octopod on my iPad for remote access and monitoring and Octopod supports my Pi cam without any hiccup.

It works at 720p for me. *shrug*

You have 720p video live feed? Because me I was only able to get a still frame (picture) at 720p. And Astroprint support was unable to solve the issue. They said they would need to test in their lab a Pi 4 and the new cam v2 but they never got back to me.

Yup. Live 720p video. It sometimes takes a second or two for the video to start.

The output from the v4l2 driver isn’t something our software is current able to interpret. The output for most drivers is to give out the exact resolution supported and not a “stepwise” format. This is what I meant before by “ doesn’t advertise itself in the v4l2 driver as doing so“.

Nonetheless we will eventually support it. We just have a lot of other things to do at the moment. Also understand that in our effort to be more plug and play, we favor USB cameras as they are way more friendly for the average user.