Raspberry Pi Camera Support [SOLVED]

I just updated from an older version. I did get ti to work however by adding the modprobe command to the modules file.

I may re-create a new SD card soon to clean up some of my messing around.


Yes, that’s what the new image would have done for you.

New here, just installed AstroBox-rpi-0_9_0-20160602, updated through the webapp but Astroprint can still not find raspicam. This command ‘raspistill -o cam.jpg’ works so I know the camera is working anything else I need to do?

Please read this: Update to 0.9 not offered

Hey Daniel, I just want to make sure I am clear. Raspicam is supported in stills but not video, correct? I can get stills to work, but I cannot get video to work.

Video in Chrome 56 is broken for some reason. Video with the raspicam is supported and should work on FireFox, older Chrome version and hopefully future ones too

Here is something strange that I don’t understand. Using pi camera v2, I can view video or snaps on my Mac and Samsung pad using Firefox. But when I try the same thing on my iPhone or iPad, it tells me I am using Safari and it’s not supported even though I am in fact using Firefox. Same thing happens when I try google chrome. Any ideas?

Firefox ( or chrome ) in iOS still uses the safari engine underneath. It’s a limitation of iOS

So I can’t do this on an iOS device? Wow…

That is correct @John_How Apple is still working on their webRTC support. Not really something we can help with.

I had some issues and had to reflash my SD card. I then had to set up the raspicam inside Astro box. This took me forever to figure out.
The bit about how to log into your astrobox to run raspi-config (for noobi’s and idiots like me) should definately be included in the setup instructions. For me on a mac, it was so simple once I found out how. Just ssh pi@astrobox-xxxx.local. PW "raspberry"and run sudo raspi-config… but I did not know. So please include in setup instructions and just say ignore if you don’t have a camera.
Thanks and sorry bout the soapbox attitude…

For noobs the raspicam is quite complex and we discourage it

It was a piece o cake when I found the simple answer…

Hi john, can you help me with the steps??



Hi FA, the way I did it is hook my mac up to the pi with a network cable. Open a terminal window and type the following.
ssh pi@(astrobox name).local
The password should be (raspberry)
After your logged into the pi, type
sudo raspi-config
You will see a menu of things to do, one of them is to configure peripherals so you should select that and the one of those selections is to enable the camera. Do that and then close the menu using the selection at the bottom of the menu and you should be good.
When your back in astroprint go to the setup menu and look for the camera setting to enable and detect it.
If your using a PC then the procedure is the same but you need some other software to do the “ssh” and I’m not sure what that is.
Hope this helps…


Ok so I am using latest (at the time of writing 4.4.2018) astrobox soft, enabled camera, ssh, spi, i2c in raspiconf, then modprobe bcm2835-v4l2 and pi camera is still not detected. It happens so fast I doubt it is even trying to detect it. No lights on camera as well. FAQ, despite what was mentioned about updating it here, does not mention pi camera.

any help is appreciated

I managed to get it to detect camera however no image is streamed. At any resolution. Still ‘loading’

1 Like

I just hit the same issue with latest AP on a RPi Zero W. Camera is detected, but it doesn’t get past the “preparing video” message, accessed from firefox on windows. No solution to this?

i have the zero w h used the raspi v2 8mp camera it would not detect it. now i have the the 4port usb hub hat /uart module on and plugged in a logitech webcam and both cameras are detected now but will not stream video. i get uanble to start web rtc… when i unplugg web cam astro astro print doesnt see the raspi cam ??? cant find anything like this been trying…

FWIW, why is this topic marked as solved? For instance, I’ve never been able to get the camera to actually start streaming (despite it IS detected) on a RPi Zero W.