[SOLVED] Problem connecting to Prusa MK3S


I have a Prusa MK3S and Astrobox Touch (on my own RPi 3), and it can’t connect/find the printer. When I plug in the USB cable it detects the serial port, it shows up on the 3D Printer screen, but it can’t successfully connect to it. I select the MK3 (even if it’s a MK3S, but it’s not a valid option). Any ideas? This is supposed to be a supported printer right? I purchased the AstroTouch (license) because it said it would be 100% supported. The printer shows up in the Slic3R software on my Mac, and I successfully updated the firmware to 3.7.1.


Make sure the RPi Port is off. You can find that in Settings on the printer’s LCD. Also use 115200 as the baud rate.


Yup, that did it, it’s working now, thanks!


Out of curiosity. Was it the RPi Port or the baud rate?


The baudrate did it, RPi port was already off. And I tried to change it initially, but nothing happened (it still didn’t connect). I think it took a reboot until it was successful (but before that I had given up and contacted support). But I’m not sure 100% sure about the steps I took, I tried it from both the touch screen and the local web server, but I was also messing with the serial log, so now after the fact I don’t have the clear steps for exactly “fixed” it, or how to reproduce the issue.

I was able to start a print directly from the AstroBox late last night. There are a couple of UX problems IMO, I’ll be happy to share those if you think they are valuable (like when I tried to print from Thingiverse it downloaded the files but then I couldn’t find them anywhere). The print went to about 70% then my RPi crashed and the print got ruined, not sure what’s going on with that. It was a hard crash though, the RPi completely locked up, no pings or anything. I’ll retry later.


The “crash” could be related to insufficient power, bad cable or other things. Maybe read this and see it points you in the right direction: https://astroprint.zendesk.com/hc/en-us/articles/115001797403-Why-does-my-printer-disconnect-in-the-middle-of-a-print-


Yea, I think you’re right, dmesg reports under-voltage. I’m not blaming AstroBox for that :slight_smile:
I changed the power supply and put the camera on a powered USB hub, it’s still reporting under-voltage, but the next print was successful (but also smaller). However at the end of the print the printer just stopped with the head right on the printed part, it didn’t move away or anything so I could remove the part. I’m using the built-in profile for the Prusa MK3, is there a setting for this or?