Control astroprint on astrobox


I have a Raspberry Pi 3 that´s im running Astroprint on and it´s working excelently. I have the raspberry pi 7 inch touch screen laying around. Im wondering if I could in any way connect the screen to the rpi thats running astroprint and get an GUI up so that it would be possible to go on to the astroprint website via the rpi. This would allow me to control the printer from astrobox itself.

The first thing I tried was to type startx in the terminal but I just got the answer that it´s not recognized as a command. It seems like some people has got it working but no one is explaining how they did it.


you might look at this forum thread:

I used it to get my Pi to boot into a GUI so I could use a monitor and KB/mouse…not sure it is the same with
the tough screen but seems like if you can get the screen working this would be similar.


Okay, thanks.

The GUI you get when following the thread is that the raspbian GUI or is it totaly different?


It seems to be the standard one although it seems a little different from my older units…I am guessing that is due to updates in the Raspbian distribution…but I can’t confirm it…for me it was good enough, with basic GUI and browser and stuff I never bothered to try out on my printer box.


I found that the instructions posted to the above link “Controlling Astroprint directly from installed Pi?” was lacking one additional command:

sudo apt-get install xorg


[SOLVED] Controlling Astroprint directly from installed Pi?

Awesome find Darrel. Literally the missing piece to the puzzle.


Hi I just got my first raspberry pi with the touch screen and I have been trying to set this up for a couple days now. I installed astroprint and set it up while connected via the Ethernet port (because I don’t have the extra wifi dongle yet) then I set up the install lights stuff. Now I have a GUI and I can get to the Astro box control panel locally, but it won’t connect to my wifi at all. I keep getting a “bad password” error. I’m positive that I am putting my password in correctly. Is this because I’m don’t have the extra wifi dongle? Even though I have it plugged in to Ethernet? Thanks for any help.


I had the same issue. I was able to have the gui boot up. However, I could not connect to the internet to save my life. I noticed that the Astroprint image was connected, because I could still use the browser on my phone and connect to it. Yet, once I was in the GUI, I could not connect to the internet, and would either get, “Bad Password” error, or “Connected”, with “Not Connected” immediately following.


Are you guys configuring the network yourselves? You should read this article as an alternative (and more advanced) method to connect the box to the internet:


I tried something similar to this… I will give it a shot again when I get home tonight. Curious though, and pardon me if I’m asking an ignorant question because I’m still learning, why would changing the configuration file make a difference when the Astroprint routine can connect, but not the GUI?

Also, since I have a special character “!” in my SSID Password, do I have to do anything special for this? I’ve read in difference places, that you have to have a \ before special characters…


The article explains a method by which we basically instruct the astrobox software to not try to connect using its network manager but trust that the underlying platform has connectivity.

The clue about the special character is important. I will try to see if that can cause problems.