Astrobox not recognized by Astroprint cloud

After upgraded my RPi 4 Astrobox to .20(4), it no longer will accept a print job from the Astroprint cloud. I’m able to connect to it wirelessly and control the printer via the astrobox.local web page and bring up astroprint via the My Astroprint Cloud but Astroprint doesn’t recognize the box when I click the Monitor button or try to print.

The rocket icon doesn’t show at all. It’s replaced by a wifi icon with a little red square next to it. In the network settings, only an ethernet interface shows (which is not connected) but no wireless interface. However, the wireless interface is working since I can control the printer from the utilities page. Also, it must have had an internet connection prior to the update since it downloaded the update with no problem.

I tried doing first run again by editing config.yaml and seemed to be able to log into my account but it still didn’t work after that.

Any ideas? Thanks.


I’ve tried everything I can think of and can’t get the Astrobox to communicate with or have the astrobox software show the wifi connection in its internet settings. I’ve searched every relevant post on this forum, trying each solution, and nothing works.

For now, I’ve gone back to using PrusaSlicer with the API to send gcode to the Astrobox. If anyone has an idea what else I can look at, the help would be greatly appreciated.