Astrobox not seeing external drive (or files)


#1

Hey there,
So I’ve tried multiple thumb drives in the USB ports on my AstroBox but the AstroBox does not recognize the external drive…that is until I remove it. Then it says “external drive removed outwith ejecting”.

I was trying to print a few files through astrobox and I currently dont have internet in my new office. Any thoughts on what might be causing this? My current workaround is to detach the astrobox and take it to a place with internet…load the files directly to the box through the web…and then bring it back and hit print. Seems silly.

Thoughts?
-ryan


#2

Not sure it is still this way but I think the astrobox stores files on the microSd card not on a usb stick. Also is the usb stick formatted correctly? I’ve never tried doing this so I really have no idea.


#3

@Darren_DeVecchio, since a few releases ago, we support reading and printing from external USB sticks. @Ryan_Harrison, What version of the software? have you tried different USB drives?


#4

Hey Daniel,

Sorry for my delayed response. I’ve tried different drives. Same issue. Latest firmware I think AstroBox_Touch - v0.13(11). I found a stray wifi signal near my new office i can use for now but I’d love to get this figured out.

thoughts?


#5

The latest is 0.13(12). However nothing was done to the thumb drive system because we haven’t had any reports of it not working before this.

Can you describe how you’re trying to access the drives ?


#6

Hey Daniel,

I coppied the GCODE files (created in Simplify 3D) onto my thumb drive. I put the thumb drive into the astrobox. Navigated to “external drive” for the files.


#7

Have you tried more than one drive ? Could you send us logs ?


#8

yup different thumb drives. No external drive found, but get an error once removed for not ejecting properly.

hoe does one create a log?


#9

You can access your AstroBox using it’s Web UI by going to its IP address from a browser in a computer on the same network. Find the IP from your touch going to Settings / Network / Internet then use that IP in the browser like http://ip_address

Once you see the web ui, navigate to Settings / Software / Advanced from there you can send logs to us.


#10

ok thanks. I followed your instructions and sent you the logs requested.

thanks,
-ryan


#11

Here’s the error line:

2018-08-06 21:05:38,758 - astroprint.externaldrive.linux - WARNING - Partition mount failed with return code 32: mount: unknown filesystem type 'exfat'

It appears that we can’t mount that type of filesystem. How did you format that card?


#12

Hey Daniel,

I never intentionally formatted any drive I was trying to use. I have 3 different thumb drives/ micro SD cards that bounce between different computers and digital cameras to move files around. Is there a proper format it needs to be in order to read?


#13

extFAT seems to be common among SDXC cards. It’s not supported by default in Raspbian (which we use as a base). At some point we would look into what’s required to support extFAT if it seems like a problem for most people.

For now formatting to FAT32 should work.


#14

Awesome thanks! I’ll try that. And I’ll put the extFAT as a feature request. Formatting is something I probably thought about a while ago but everything has gotten so plug and play it didn’t cross my mind to check it. Appreciate the help.


#15

Hey Daniel,

So I got arround to formatting some thumb drives to insure they were FAT32. The astrobox saw the drive, even saw the file, but gives me an error code each time I try to print. When I try and just copy the file to the astrobox it get a message saying it did so…but then I can’t seem to find the file anywhere. When I go to reload it, I get a message explaing it’s already there. Would I like to overwrite it.

So one step forward but still having issues. I’ll send the error code along to you.

Thanks again


#16

We are working on a fix for this. It has to do with some filenames. Do the file names have spaces ? What are they?


#17

It’s gcode created in Simplify 3D
And yah most of my file names have spaces or underscores.

This file was “washer jig”
I just resaved the file as “washerjig” and it seemed to copy and able to print just fine.

Wow what a difference that makes. I bet this has been the root of a few issues I was having. Glad to have this figured out.

Cheers!


#18

Thanks for confirming this. We have a fix in the next release to accept these filenames