Astroprint 0.9 Update


#1

Just completed the upgrade to 0.9 and rebooted my Raspberry Pi. I now have no camera. My raspberry pi camera worked in the 0.8.8 version but now its not even listed.

Have I missed something, which is entirely possible or should I be expecting to see some camera action?


#2

What if you go to your Astrobox Settings > Video and Re-Scan for your camera?


#3

Settings > Camera > Image / Video is empty. Nothing there at all.

I am now seeing briefly a red banner stating “There was an error getting camera settings”


#4

What camera do you have? We are now only supporting USB cameras.


#5

I’ve got a similar problem, but the camera is detected. Upgrading to 0.9 broke image capture from my usb camera (a cheapy NetFlix). Search for item 252399693306 on ebay for example. I’m using a PI 2B.

The astrobox -> settings -> camera -> image/video page lists it as “USB2.0 Camera”, with H.264 & VP8 options, 640x480 resolution (no others), 5/10/15fps rates, and raw video format only. None of the options help (I’ve tried lots of combinations).

Is there an easy way to revert to 0.8.8?
– Ian


#6

I have like many the Raspberry PI camera. I don’t remember you guys mentioning anything about a compete shift to only USB camera’s prior to the update?

{EDIT}
So I have now read your blog post again, regarding the Update (https://blog.astroprint.com/live-video-streaming-is-now-available-on-astroprint/) and there is a link “our recommended cameras” (https://astroprint.zendesk.com/hc/en-us/articles/203050005-What-cameras-can-I-use-with-AstroPrint-) and there it states “In the Raspberry Pi platform we also support the RaspiCam but remember that you have to enable it using raspi-config before it’s enabled.” Which I do have enabled. So I’m now confused by your statement of only Supporting USB Cameras.

I have just ordered a PI3 and the new Raspi Camera to accommodate this important upgrade. Now, if you do not or are not going to support the Raspi Camera then I’m kinda stuck here. I still have the 0.8(8) zip file her which I will be re-installing in order to get my printer back to where it was prior to upgrading. I’m also wondering now for how much longer there will be support for the 0.8(8) firmware?


#7

I have just updated that article to completely remove references to the raspicam so that we don’t confuse more people. While I realize that many people use the raspicam, even more people use USB cameras supported by the V4L2 driver system and we started moving that way. The new update completely re-architected the camera system in order to support live-streaming and more sizes. All frequently requested features.

For the time being we’re “pausing” support for the raspicam until we can properly assess the level of support it has for the V4L2 driver system and can properly test it.

Sorry for the misundertanding and we hope we can turn support back on for the raspicam soon. In the meantime there are many affordable USB cameras in the market.


#8

Thanks for the clarification. I wished you had updated your documentation prior to me pushing the update button. As now I have to re-install unless you can provide me with someway to downgrade I feel like I am at a crossroads. I have a system here that is not working and for the foreseeable future it isn’t going to work with my current hardware. I have preferred to use Astroprint over Octoprint but now I feel I am being pushed in that direction and there is now way back and as I can’t find the 0.8(8) firmware. I really feel disappointed that you guys didn’t let us end users with Raspberry Pi gear know that we wouldn’t be fully supported. Sorry to be so negative at what should be a really exciting day but I just really feel let down by you guys.


#9

We don’t have the 0.8(8) as a flashable image but you can flash this one and update to 0.8(8)

https://s3.amazonaws.com/astrobox-releases/AstroBox-rpi-0_8_3-20151002.zip


#10

Same problem here… after flash 0.9, my camera is detected (Genius LightCam 1020), but no image…


#11

What does that mean no image? no video? no photo? what browser are you on?

Take a look at this to see if it helps: https://astroprint.zendesk.com/hc/en-us/articles/209139946-Browser-support-for-Live-Streaming


#12

Using latest 64b FireFox… my setting are H.264; 1280x720; 15 FPS and camera is detected as LightCam 1020. Changing resolution, FPS and encoding nothing changes. No photo & no video.


#13

It’s possible that this camera is not supported. Sorry we can’t test with all the cameras in the market. We’re relying on the manufacturer’s implementation of the V4L2 driver.

In order to investigate this further, could your try again to generate logs and send them to us (please add a reference to this thread on the log description).

You can send log from the AstroBox settings UI in the advanced section.

Thanks for your help!


#14

Of course! I selected this cam, bacuse is only one cheap, with night vision. I dont want use lamp all the nights :smiley: Sending logs right now! :wink: In version 0.8, was worked flawlessly.

/edit: logs sended :wink:


#15

Thank @Jan_Pichrt Good info that it worked before. We did change a huge part of the camera system BUT in 0.8(8) we also used the V4L2 system. However it was just for still pics so the code and subset of features of the drivers were much simpler.

We’ll get this sorted out. It’s just hard for us to get all cameras at first. Hang in there :slight_smile:


#16

Got the logs! Definitely a bug that for some reason shows up with your camera model and not in others. I’m going to order one and fix it in the next release.

Thanks for reporting !


#17

@Jan_Pichrt Would you mind adding a support ticket at https://astroprint.zendesk.com so we can ask you more questions. It’s better handled there since we think this is an error that we need to fix. The forum readers won’t benefit much more from this conversation.


#18

Hi, I also have a similar problem now with 0.9(3) with my raspberry camera module. It worked fine in version 0.8(x) for still pictures. But now I cannot stream video or take pictures from Astrobox (local ip) or astroprint.com.

The camera is detected and I can set format, resolution and fps. But none of the combinations work (I tested in Chrome or Safari). From astroprint.com I get the error something about changing resolution. From the local ip, it just gets stuck in e.g, “taking picture” and nothing happens. I can take pictures with raspistill and also access the camera stream with ssh in Android.

I have not tried with other camera (I have no usb cameras), but I plan to get a cheap one and try later


#19

I have tried now with Genius WideCam 1050 (borrowed to test). I have exactly the same problem. It gets detected by Astrobox as WideCam 1050 and can change the format, resolution, etc. but I cannot take pictures or stream video regardless the format and resolution.


#20

I downloaded the image available in downloads 0.9(3) and that solved the problem. I think the main problem was that I started with previous firmware versions and have been updating. Something must have gone wrong. A fresh install from the 0.9(3) image solved it.