Astroprint cannot login (2018)


#1

My Astroprint setup randomly stopped working, so I reformatted yesterday with the latest download (on 26th May, 2018).

Despite setting up the network correctly (I can connect locally, and connect to https://api.astroprint.com/check and get an OK back), I cannot log into Astroprint from the Pi. I get a message "

In Chrome’s debug, I get this console message: Failed to load resource: the server responded with a status of 503 (SERVICE UNAVAILABLE) /api/setup/astroprint
The exact URL it is trying to reach is http://duplicator.local/api/astroprint/private-key

Despite this, I was able to do a software update to 0.12(5) today with no issues, from the local web front-end.

I notice the “Internet” settings option is completely blank, despite other settings being correct. I manually setup internet using wpa_supplicant, which worked before I do regularly on Pis with Raspbian.

I notice a few other topics with the same issue, but before a certificate expired. There doesn’t appear to be anything going wrong in /var/log/astrobox/astrobox.log

Also I haven’t reset my password in ages, I noticed this was a solution to another person’s related issue.


#2

Is this still a problem? 503 means a temporary error. There was a service interruption over the weekend that was resolved. Could you try again?


#3

I’m traveling for work - I’ll give it a shot Thursday


#4

Still no luck, same error, device connects to internet.


#5

Connecting the network cable worked. I’ll can leave that in, but wifi would be good to have.


#6

It might be bad reception or something similar. Most people connect with WiFi successfully


#7

Not unless Astroprint goes out of it’s way to be difficult here.

I can connect to the internet, via wifi, completely fine via wget, and the devices are in the same room about 2 meters apart. wget on the API status check works fine, and I am getting a response to the login, it’s a 503. If I do a POST request via Python and don’t submit the password I get a different 40x error. I get the 503 when both username and password are provided. Also, as mentioned, an update works.


#8

Could you send us logs via Settings / Software / Advanced?


#9

Hi, I just registered a new account. I can log in via the web interface fine but trying to log in with the iOS app I get an error message telling me I have no internet connection on my phone which is completely wrong as I have both a stable 300mb WiFi connection!???


#10

Are you using VPN? or a proxy?


#11

Neither. This is the same whether I connect via any WiFi network or any 3/4G mobile network, no proxy or vpn at all.


#12

Something might have gone wrong during the installation. We have it working fine here. Have you tried uninstalling and installing again?