Astroprint login not connecting to Astrobox


#1

Thursday 11/15/2018
Astrobox = Raspberry Pi + correct Wifi dongle + USB cable to 3D printer + WiFi router
0.11(12) firmware
Wifi verified and working, can login to Astrobox.
Astrobox connects to 3D printer, verified.
unsuccessful connecting to Astroprint Account through Wifi.
Was connecting for weeks and months. Why now not connecting?

Action taken: Reset to Factory settings.
Went through setup wizard unsuccessful - not connecting to Astroprint Account.

Reset to factory settings. Used setup Wizard again, and Again unsuccessful connecting to Astroprint Account. The icon in top right of menu shows no connection to Astroprint account.

Problem: I have one 3D printer connected to the same Astroprint account that works.
Why does this one suddenly not connect?
Tried connecting to other Astroprint accounts have setup and they don’t work either.


#2

Monday November 19, 2018
After flashing firmware 0.13(16) update, unable to register Astrobox with Astroprint Cloud account.

I have FIVE astroboxes I can not register with the Cloud accounts
Why?
Richard


#3

One possible solution:
We are using Raspberry Pi 2 boards
There must be something in the 0.13(16) firmware that does not have the right driver for connecting to Astroprint account that requires the Pi3
We now need to test upgrading to replace FIVE Pis to use Pi3


#4

Raspberry PI 2 (and 1) are supported. The problem might the dongle. You do NOT need to upgrade your Pi. You should try looking at other alternatives. Try setting your devices using this method: https://astroprint.zendesk.com/hc/en-us/articles/360000337286-How-do-I-setup-AstroBox-Gateway-without-dongle-hotspot-


#5

“This will launch your browser into the setup screen of your AstroBox where you will be able to connect it to your WiFi. Once that it’s done, you will be able to disconnect the Ethernet cable.”

There is no issue connecting to Wifi, I can log onto the Astrobox, I can control the printer from the dashboard on the Astrobox. The printer is connected to the Astrobox and working. I can do anything and everything on the Astrobox. The one connection not allowed is to the Astroprint Cloud account using the setup wizard.

I am going to try to drop back to prior version.


#6

Astrobox Status

When I flashed a few Astroboxes with current version 0.13(16) of firmware, the setup wizard would not allow a connection with Astroprint Cloud software. As a result, we can not use them to send STL files, and can not Slice the STL file to create gcode for the 3D printers. We are able to connect through the Astrobox to the 3D printers, to connect via wifi to the router, and to connect to the dashboard on the Astrobox.

Astrobox Gimli was not updated and continues to work using version 0.11(12). No changes were made to this Astrobox. The Netgear78 router needs to be connected to the Internet (orange wall plug) for this printer to work.

Astrobox Boromir was purchased from astroprint.com for $100, assembled and works using version 0.13(16). Again, if the Netgear78 router is working, then this Astrobox will work.


#7

What happens if we leave # for #static router and #static domain_name_servers?

We have Astrobox as end user device and using MAC address the school district assigns a static IP address. We connect via ethernet cable to a school district Switch with 24 ports. Edit the dhcpcd.conf file:
interface eth0

static ip_address= 10.206.7.185

(static IP assigned to Astrobox)


#8

Also, we won’t be using Wifi connection so we don’t need this?
interface wlan0

static ip_address= 10.206.7.185


#9

Once you think you have an internet connection, however the Astroprint account in the setup wizard does not work, the key is manual connection to internet, Wifi or ethernet:
Change the AstroBox settings to let the software know that you will manually configure the internet connection.

ssh nano /etc/astrobox/config.yaml

(Below note the indentation, exactly 2 spaces before “manager”)
Add these two lines to the file:

network:
manager: manual

To save the file:
Hit Ctrl + X (to exit)
Hit Y (to save)
Hit ENTER

Reboot the Pi by power off and then on,
Or:
$ sudo reboot


#10

After restoring Astrobox to “factory settings” had to go back and log into Pi and change the /etc/network/interfaces in order to add back in the lines
network:
manager: manual


#11

At Southridge High school in Beaverton OR
As of today, have successfully connected four DIY Astroboxes and one purchased Gateway box, to three Prusai3 and two Delta style printers.
updated all the astroboxes to version 0.14
Connected to free Astroprint accounts, 2 printers per email.
Still need to unclog a Makerbot Rep2 and get it reconnected to another DIY Astrobox.


#12

Hello, I am an intern who is having problems logging into AstroBox


Every time I sign into the account (which works on the computer) I get told that there is a login error and trying to reset the password to fix that problem leads to what is shown on the image above. I tried turning on and off the AstroBox and even rebooting the AstroBox to factory settings

Can someone help he fix this issue, it will be greatly appreciated.