Astroprint on Orange Pi Zero


#21

I managed to run AstroPrint on BeagleBone Green installing everything manually on Debian. I don’t have OrangePi Zero but entire process should be the same…
My fork: https://github.com/bula87/AstroBox

I managed to run web gui, and even update SW via cloud update…

Update:
I managed to run wifi on BBg and tomorrow I will connect the printer but there shouldn’t be any problems. So, it looks like, beaglebone also could be a AstroBox platform.

PS. there could be some missing packages (I instaled it ad-hoc so I could miss something in setup script). When all functionalities will be up and running I will do the full process again to add missing parts.


#22

is this worked out? Can it all work on the cloud etc but without camera now?


#23

Sorry, I had busy time with some prints and I hadn’t had a chance to check BBG - printer connection. Will do this today evening. And USB camera should also works. I think I still have one, so will check also.


#24

So I checked it yesterday and there are still 2 issues:

  • Astrobox process doesn’t start automatically
  • my camera was detected but gstreamer crashed, it could be problem with my camera, will try to fix it

But the rest, cloud connection, printet connection and control works fine, at least for my sailfish printer.


#25

Ok, I am just trying to build a print server for my buddy who got a printer recently, I have an Orange Pi Zero 512mb to give him so no camera anyhow :slight_smile: I just want to put it on his marlin printer and connect it to his wifi AP, I like astroPrint because it has cloud connect to check on prints and notify when its done.
He wont even have a camera lol.

but autostart the process is important :slight_smile:

TQVM


#26

So, today I managed to fix a issue. It was just a problem with my bbb debian version. By default it has installed http server with some beaglebone tutorials itp. and it blocked start of AstroPrint. I added also one new package to dependencies list. I forgot to install haproxy and I had to use port 5000 and ip provided by router. now it works as official release.
Tomorrow or during the weekend I will reflash my sd-card and do everything from the beginning to catch all missing packages.


#27

Eagerly await :slight_smile: Will you produce a flash able image or must I work through a set of instructions?

tqvm for the effort btw


#28

You will have to ssh to your Orange Pi zero, do a git clone of my fork and execute setup command.
I don’t have orange pi, so I cannot prepare flashable image.
But if everything will work you will be able to dump your sd card for future


#29

sorry for being a newbe when it comes to this sort of stuff, I flashed Debian server onto the sd card, I got SSH into it, ran ‘sudo apt-get update’ and ‘apt-get upgrade’ so thats done.

I do not know how to fork or any of those things. Could you paste the lines I need to follow or is that too much?


#30

Follow instructions from readme file:

So, just ssh to your board and:
cd /
sudo git clone https://github.com/bula87/AstroBox.git
sudo /AstroBox/setup.sh


#31

Thanx, I am discovering that debian server has some issues with Opi Zero Wifi interface, your fork should work on Armbian just the same right?


#32

Yep, it is based on debian, so should be ok


#33

I couldnt get much working on debian so I flashed up Armbian image and updated etc
setup my wifi all good, everything seems to go great up to the setup.sh - then all I get is command not found but when I ls I can see the file is there…
Can you help me work out whats going on with this?

root@orangepizero:~/AstroBox# sudo /AstroBox/setup.sh
sudo: /AstroBox/setup.sh: command not found
root@orangepizero:~/AstroBox# sudo setup.sh
sudo: setup.sh: command not found
root@orangepizero:~/AstroBox# ls
LICENSE README.md requirements_dev.txt requirements.txt run set-initial-hostname setup.sh src toInstall
root@orangepizero:~/AstroBox#


#34

you need to clone it to root directory /
now you have it in ~/AstroBox and should be in /AstroBox
Now I saw also that I forgot to add correct rights to file setup.sh. I will fix it on my git in a minute.

UPDATE:
I made some changes to the script files. So it is better for you to clone repository one again.
so:
sudo rm ~/AstroBox -rf
cd /
sudo git clone https://github.com/bula87/AstroBox.git
sudo /AstroBox/setup.sh


#35

seems to be some difference from from BBB to OpiZero this is what I get at the end of the setup.sh

Setting up haproxy…
Setting up local DNS
Enabling powercheck to start on bootup…
Enabling astrobox to start on bootup…
debian
Failed to disable unit: No such file or directory
Failed to disable unit: No such file or directory

then it locks up and wont respond to anything. I have to reflash the armbian image to get back in…


#36

Hi,
This two are ok, I added 2 commands for beaglebone but if there are no such processes it is still fine.
How are you connecting your Orange Pi to router? via wifi or ethernet?
There is no VM for arm processors and unfortunately armbian doesn’t support any of my boards :confused:
You can do 2 things, on the beginning try to comment out last command from setup.sh (reboot) and without rebooting try to run astroprint manually:
sudo python -OO /AstroBox/run --config /etc/astrobox/config.yaml --host 127.0.0.1
and see if it will fail.
And other thing is, if you are able to expose your orange pi to internet I can ssh to it and check what is going on.


#37

I am only working on this every here and there as its a family weekend and I gotta do the dad/husband thing :slight_smile:
priorities :slight_smile:
I dont mind letting you into the opi but I will try to get things going as you last put it first, maybe tomorow…

thanx I will PM you after I give those things a go

Oh I forgot to answer your question! I am starting with wired to my network and first thing I do is set it up to go via wifi. Same subnet and everything, I can SSH in from either just fine, then when wifi is in place and working I disconnect wired and move onto sudo apt update/upgrade and then I do your GIT CLONE.


#38

Thanks for access to your orange pi, I already fixed your instalation, so you can start to configure your AstroBox via http at port 80 :slight_smile:
The problem was lack of python-gobject in armbian, so I just installed it and now everything should work.
I also alredy fixed setup.sh script on github, so now everything should be automagically installed.
Enjoy!


#39

Thanx for all your help Wojtek!
I put together a set of instructions to help other newbies with this, I have tested and this does work on my Orange Pi Zero!

Use Etcher to flash this image to your microSD card (I used a 16gb kingston and I dont think you should use smaller than 8gb): Armbian_5.38_Orangepizero_Debian_stretch_next_4.14.14.img
You can get that image here:
https://www.armbian.com/orange-pi-zero/
Connect via wired lan first, then power it up!
boot up OpiZ and SSH into wired lan IP (get this from router or from ipscan tool)

Get thru the first run stuff, then these two steps:
sudo apt update - this will take 5 min or so
sudo apt upgrade - 10 to 15 min or so
once these are done, do your wifi if you want to use the wifi instead of wired ethernet. Skip if you want ethernet.

Use this command to setup wifi
sudo nmtui
once your wifi is setup shutdown the Opi and unplug the ethernet cable. Boot back up and find your new wifi IP and SSH into that.
to use the shutdown command:
shutdown now

Up to this point what you have done is pretty standard first run stuff for any Rpi, Opi, BBB etc

Download/clone AstroPrint repo with this command but CD / first to ensure your in root dir
cd /
sudo git clone https://github.com/bula87/AstroBox.git

Install/Setup with this command:
sudo /AstroBox/setup.sh

When its all done you should be able to open AstroPrint on your web browser via your Wifi IP like any other build.


#40

No problem, I am happy that this works :slight_smile:
One tip:
I think it is better to do installation of astroprint via ethernet cable, and during first boot of astrobox, configure wifi connection via astroprint wizard. At least it is easier for me, I hate all this console stuff on linux to connect to secure network :stuck_out_tongue: