Camera error Creative HD 720


#1

I am using a Creative 720 camera on the latest 0.14(0) firmware. I was told that I needed to enable port 443 in my XFinity modem firewall, which I have done by using the port-forwarding option. All I get is “camera error”. I went into the video settings in the A-T and saw that the encoding was set to VP8, which is the same setting I use for my iPhone, iPad, and MacBook Pro, via your cloud settings. I changed the resolution setting from 640x480 to HD (1280x720). I left the rotation at “no rotation”)

If I go into “test” and click “Start video” it says “preparing video” and eventually the screensaver kicks in, and when I touch the screen it is back on the “Start video” page again.

It appears this camera is not compatible with the AstroBox Touch. Unfortunately, I have no other USB webcam to try. Any suggestions would be appreciated.


#2

We only test with the cameras listed here: https://astroprint.zendesk.com/hc/en-us/articles/203050005-What-cameras-can-I-connect-to-the-AstroBox-

We’re unable to test with every camera in the market so have picked a few at different price points.


#3

I went to the list of tested cameras. I bought one of them, the Logitech C615. When I tried to connect from my iPhone, it told me that I needed to select the format H.264. I did this and got the same camera error as before. I tried resolution of HD 720p and HD1080p, with no change in behavior. I have rebooted the box twice, no change in behavior. Mostly, the screen keeps saying Preparng Video until it drops into screensaver nide. When I click on the screen, ir returns m.“Start Video” screen.

i can take still pictures, but not videos.

Note also that you makk the "mirror horizontally: and “mirror vertically” options mutually exclusive. Ain’t so, guys; if I MH then the extruder appears to be in the right place (it is parked on the left) but the image is upside-down. If I MV, the image is right-side-up but, as shown in the screenshot from my iPhone, reversed left-to-right. I need both. The camera mount I got places the camera upside-down. Or I could fix it by having you give me not just +90• and -90• but also rotate 180°, which would simplify things tremendously.

So why doesn['t the camera you say works actually work? And what do I do to get video?

joe


#4

The camera does work (as demonstrated by your ability to take photos). The failure to see video might be related to network conditions. We use WebRTC to delivery video. In some cases, some networks might not support this protocol.

We tests with these cameras and both video and photos work in the environments we test with.


#5

I am using Chrome on an iPhone with the latest iPhone software (I saw that Safari was not supported). I get the same problem using Chrome on Mac OS X (Mojave). I get the same problem using both Edge and Chrome on Windows 10 (WebRTC says it supports both). However, when using Chrome it did pop up a message that it was “unable to start WebRTC”, a typical useless message by a lazy programmer (why did it fail? What is missing? Inquiring Minds Want To Know).

The WevRTC site says nothing about any download being required.

When I reported this earlier, I was told it was likely the camera that was failing. So I got a new camera, and now I’m told that it might be a software problem (you could have said this in the first place and saved me $35).
joe


#6

Your original request didn’t say that you were able to take photos. It is this part that tells me the camera work. Also the 720 is not a supported camera, it might work but we just don’t know. We can only test with a few cameras and have chosen from a wide range of price and quaility. I stand by my initial response which is the most appropriate given the information provided.

Regarding WebRTC: even though the browser supports it, your network might be preventing the opening of the ports required by its P2P communication.

Maybe take the box and your computer to a friend’s house and try there to rule out network configuration problems. Like I said before, we constantly test with that camera without problems.

And to correct something you said for others that read this: Safari is now supported ( it has been for a while )


#7

Here’s a good post on how WebRTC works. The signaling and Peer to peer channel opening section might help you find out why it’s not working on your network.