Cannot connect to Astroprint.com


#1

I set up my raspberry pi to run Astroprint. However, it does not show up in my connected devices section. I am able to connect locally to it, and I can initiate prints from the local interface. When I want to slice it opens up the Astroprint cloud slicer and works fine there but I want to be able to manage my printer remotely. I am all updated and it says I’m signed in on the slide out menu. The rocket in the top right is red and says not connected.

When I was setting up the raspi, I booted with a monitor and keyboard plugged in and set up my network that way.

I guess I’ll try where I connect to the hotshot and set it up.


#2

Are you able to see your gcode files from the box?

If your rocket is red, it means it can’t reach out servers or you’re not logged in


#3

I’m having this same issue. I’m NO noob to 3d printing nor networking issues, but this one has me stumped… I can log into astroprint.com from many devices with my username and password, I can connect to the astroprint box, I can connect the astroprint box to the internet - the only thing I cannot do is 'log the astroprint box into my astroprint account" - I keep getting an error that my username / password is incorrect???

What causes this and what is involved in fixing it?


#4

I am having the exact same problem. It looks like I wrote this letter.


#5

with the astroprint image on the Pi, I can ping www.yahoo.com, but I cannot ping www.astroprint.com . this is the reason i cannot sign into the account


#6

Having the same exact issues. I am able to control my printer from the local address but I am unable to login to my astroprint account. Keep getting the error “Astroprint.com can’t be reached”. I can login to my account but cannot sync my local printer to my account. Please help, this is driving me crazy.


#7

Your printer is somehow not connected to the internet or doesn’t have a valid DNS configuration. Also you can look at logs at /var/log/astrobobx/astrobox.log to see if an error shows up.


#8

I have the same issue. All weekend I tried to connect my printer to the cloud. I tried Astroprint and also the plug-in for octopi. On my local network I can control and see my printer but I am not able to connect it to the Astrocloud. When using the plug-in it shows me a green box saying octopi connected to the cloud but right after that a red box shows up saying box router error. I tried the octoprint anywhere plug-in and could see my cam online but no controls. Is it possible that something times out, because I am on satellite internet and have 700ms ping?


#9

Yes. I don’t think that a satellite connection supports the persistent WebSocket connections that we need. We have seen this before.


#10

If you really need to control your printer remotely, and your internet connections allow you to connect through ssh, you can tunnel the astrobox 80 port to an external server (AWS or any other linux server) via ssh (reverse ssh tunneling), and then use this server as bridge between your phone and astrobox. Your will be able to use it in the same way as you were in the local network.


#11

Assuming this thread isn’t completely dead yet, I’m having a similar issue. I can log into the cloud everywhere else (desktop, mobile app, cloud website, and the local box itself). However, the astrobox won’t “link” to the cloud (rocket stays red). Based on what I’m reading above, sounds like it could be related to the high latency satellite connection that I’m running it over (~670 ms). I did run the echo test at websocket.org (https://www.websocket.org/echo.html) and it was fine, but with the higher traffic, perhaps that’s the issue.

I checked out the log, and this is what it’s saying: “Error - Error connecting to boxrouter: Invalid response status: 502 Bad Gateway”

Some other info on my setup: running this on a Raspberry Pi 2B, with Edimax wifi adapter, Ubiquiti/Unifi hardware for local network, satellite connection (no webserver yet)

Thanks in advance…


#12

Your network is blocking websocket connections