Cannot install Astroprint on Octoprint on windows

I have a laptop running octoprint and when i try to install Astroprint, it does not show up. If I look at the folders, I can see the Astroprint folders. I am trying to install it from the plugin manager in Octoprint

I was able to install this on my other printer that is on Octoprint w/ raspberry pi.

Thoughts?

Here are the results when I try to install

Installing plugin “AstroPrint Cloud” from https://github.com/AstroPrint/OctoPrint-AstroPrint/archive/master.zip...C:\Octoprint\venv\Scripts\python.exe -m pip --disable-pip-version-check install file:///c:/users/tekjo/appdata/local/temp/tmp4ublyp2n/octoprint-astroprint-master.zip --no-cache-dirProcessing c:\users\tekjo\appdata\local\temp\tmp4ublyp2n\octoprint-astroprint-master.zipPreparing metadata (setup.py): startedWARNING: Ignoring invalid distribution -ctolapse (c:\octoprint\venv\lib\site-packages)WARNING: Ignoring invalid distribution -ctolapse (c:\octoprint\venv\lib\site-packages)Preparing metadata (setup.py): finished with status 'done’Requirement already satisfied: OctoPrint in c:\octoprint\venv\lib\site-packages (from AstroPrint==1.6.5) (1.8.4)Requirement already satisfied: ws4py==0.3.4 in c:\octoprint\venv\lib\site-packages (from AstroPrint==1.6.5) (0.3.4)Requirement already satisfied: requests_toolbelt==0.8.0 in c:\octoprint\venv\lib\site-packages (from AstroPrint==1.6.5) (0.8.0)Requirement already satisfied: Pillow in c:\octoprint\venv\lib\site-packages (from AstroPrint==1.6.5) (9.0.1)Requirement already satisfied: requests<3.0.0,>=2.0.1 in c:\octoprint\venv\lib\site-packages (from requests_toolbelt==0.8.0->AstroPrint==1.6.5) (2.27.1)Requirement already satisfied: OctoPrint-FileCheck>=2021.2.23 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2021.2.23)Requirement already satisfied: OctoPrint-FirmwareCheck>=2021.10.11 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2021.10.11)Requirement already satisfied: OctoPrint-PiSupport>=2022.3.28 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2022.3.28)Requirement already satisfied: argon2_cffi<22,>=21.3.0 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (21.3.0)Requirement already satisfied: cachelib<0.3,>=0.2 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.2.0)Requirement already satisfied: Click<9,>=8.0.3 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (8.1.3)Requirement already satisfied: colorlog<7,>=6 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (6.6.0)Requirement already satisfied: emoji<2,>=1.4.2 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.6.3)Requirement already satisfied: feedparser<7,>=6.0.8 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (6.0.8)Requirement already satisfied: filetype<2,>=1.0.7 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.0.10)Requirement already satisfied: Flask-Assets<3,>=2.0 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.0)Requirement already satisfied: Flask-Babel<3,>=2.0 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.0.0)Requirement already satisfied: Flask-Login<0.6,>=0.5 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.5.0)Requirement already satisfied: Flask-Limiter<3,>=2.6 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.6.2)Requirement already satisfied: flask<2.2,>=2.1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.1.2)Requirement already satisfied: frozendict<3,>=2.0 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.3.2)Requirement already satisfied: future<1,>=0.18.2 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.18.2)Requirement already satisfied: markdown<4,>=3.2.2 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (3.3.7)Requirement already satisfied: netaddr<0.9,>=0.8 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.8.0)Requirement already satisfied: netifaces<1,>=0.11 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.11.0)Requirement already satisfied: passlib<2,>=1.7.4 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.7.4)Requirement already satisfied: pathvalidate<3,>=2.4.1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.5.0)Requirement already satisfied: pkginfo<2,>=1.7.1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.8.2)Requirement already satisfied: psutil<6,>=5.8 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (5.9.0)Requirement already satisfied: pylru<2,>=1.2 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.2.0)Requirement already satisfied: pyserial<4,>=3.4 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (3.5)Requirement already satisfied: PyYAML<6,>=5.4.1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (5.4.1)Requirement already satisfied: sarge==0.1.6 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.1.6)Requirement already satisfied: semantic_version<3,>=2.8.5 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.9.0)Requirement already satisfied: sentry-sdk<2,>=1.5.7 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.5.12)Requirement already satisfied: tornado<7,>=6.0.4 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (6.1)Requirement already satisfied: watchdog<2,>=1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.0.2)Requirement already satisfied: websocket-client<2,>=1.2.1 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.3.2)Requirement already satisfied: werkzeug<2.1,>=2.0 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2.0.3)Requirement already satisfied: wrapt<1.14,>=1.13.3 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.13.3)Requirement already satisfied: zeroconf<0.34,>=0.33 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.33.4)Requirement already satisfied: zipstream-ng<2.0.0,>=1.3.4 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.3.4)Requirement already satisfied: blinker<2,>=1.4 in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (1.4)Requirement already satisfied: regex in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (2022.1.18)Requirement already satisfied: unidecode in c:\octoprint\venv\lib\site-packages (from OctoPrint->AstroPrint==1.6.5) (0.4.21)Requirement already satisfied: argon2-cffi-bindings in c:\octoprint\venv\lib\site-packages (from argon2_cffi<22,>=21.3.0->OctoPrint->AstroPrint==1.6.5) (21.2.0)Requirement already satisfied: colorama in c:\octoprint\venv\lib\site-packages (from Click<9,>=8.0.3->OctoPrint->AstroPrint==1.6.5) (0.4.4)Requirement already satisfied: sgmllib3k in c:\octoprint\venv\lib\site-packages (from feedparser<7,>=6.0.8->OctoPrint->AstroPrint==1.6.5) (1.0.0)Requirement already satisfied: itsdangerous>=2.0 in c:\octoprint\venv\lib\site-packages (from flask<2.2,>=2.1->OctoPrint->AstroPrint==1.6.5) (2.1.2)Requirement already satisfied: Jinja2>=3.0 in c:\octoprint\venv\lib\site-packages (from flask<2.2,>=2.1->OctoPrint->AstroPrint==1.6.5) (3.1.2)Requirement already satisfied: webassets>=2.0 in c:\octoprint\venv\lib\site-packages (from Flask-Assets<3,>=2.0->OctoPrint->AstroPrint==1.6.5) (2.0)Requirement already satisfied: pytz in c:\octoprint\venv\lib\site-packages (from Flask-Babel<3,>=2.0->OctoPrint->AstroPrint==1.6.5) (2021.3)Requirement already satisfied: Babel>=2.3 in c:\octoprint\venv\lib\site-packages (from Flask-Babel<3,>=2.0->OctoPrint->AstroPrint==1.6.5) (2.9.1)Requirement already satisfied: rich<13,>=12 in c:\octoprint\venv\lib\site-packages (from Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (12.5.1)Requirement already satisfied: limits>=2.3 in c:\octoprint\venv\lib\site-packages (from Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (2.7.0)Requirement already satisfied: typing-extensions in c:\octoprint\venv\lib\site-packages (from Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (4.3.0)Requirement already satisfied: charset-normalizer~=2.0.0 in c:\octoprint\venv\lib\site-packages (from requests<3.0.0,>=2.0.1->requests_toolbelt==0.8.0->AstroPrint==1.6.5) (2.0.12)Requirement already satisfied: certifi>=2017.4.17 in c:\octoprint\venv\lib\site-packages (from requests<3.0.0,>=2.0.1->requests_toolbelt==0.8.0->AstroPrint==1.6.5) (2021.10.8)Requirement already satisfied: urllib3<1.27,>=1.21.1 in c:\octoprint\venv\lib\site-packages (from requests<3.0.0,>=2.0.1->requests_toolbelt==0.8.0->AstroPrint==1.6.5) (1.26.8)Requirement already satisfied: idna<4,>=2.5 in c:\octoprint\venv\lib\site-packages (from requests<3.0.0,>=2.0.1->requests_toolbelt==0.8.0->AstroPrint==1.6.5) (3.3)Requirement already satisfied: ifaddr>=0.1.7 in c:\octoprint\venv\lib\site-packages (from zeroconf<0.34,>=0.33->OctoPrint->AstroPrint==1.6.5) (0.1.7)Requirement already satisfied: MarkupSafe>=2.0 in c:\octoprint\venv\lib\site-packages (from Jinja2>=3.0->flask<2.2,>=2.1->OctoPrint->AstroPrint==1.6.5) (2.1.1)Requirement already satisfied: packaging<22,>=21 in c:\octoprint\venv\lib\site-packages (from limits>=2.3->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (21.3)Requirement already satisfied: deprecated>=1.2 in c:\octoprint\venv\lib\site-packages (from limits>=2.3->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (1.2.13)Requirement already satisfied: setuptools in c:\octoprint\venv\lib\site-packages (from limits>=2.3->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (58.1.0)Requirement already satisfied: pygments<3.0.0,>=2.6.0 in c:\octoprint\venv\lib\site-packages (from rich<13,>=12->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (2.13.0)Requirement already satisfied: commonmark<0.10.0,>=0.9.0 in c:\octoprint\venv\lib\site-packages (from rich<13,>=12->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (0.9.1)Requirement already satisfied: cffi>=1.0.1 in c:\octoprint\venv\lib\site-packages (from argon2-cffi-bindings->argon2_cffi<22,>=21.3.0->OctoPrint->AstroPrint==1.6.5) (1.15.1)Requirement already satisfied: pycparser in c:\octoprint\venv\lib\site-packages (from cffi>=1.0.1->argon2-cffi-bindings->argon2_cffi<22,>=21.3.0->OctoPrint->AstroPrint==1.6.5) (2.21)Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in c:\octoprint\venv\lib\site-packages (from packaging<22,>=21->limits>=2.3->Flask-Limiter<3,>=2.6->OctoPrint->AstroPrint==1.6.5) (3.0.9)Using legacy ‘setup.py install’ for AstroPrint, since package ‘wheel’ is not installed.Installing collected packages: AstroPrintAttempting uninstall: AstroPrintFound existing installation: AstroPrint 1.6.5Uninstalling AstroPrint-1.6.5:Successfully uninstalled AstroPrint-1.6.5Running setup.py install for AstroPrint: startedWARNING: Ignoring invalid distribution -ctolapse (c:\octoprint\venv\lib\site-packages)WARNING: Ignoring invalid distribution -ctolapse (c:\octoprint\venv\lib\site-packages)Running setup.py install for AstroPrint: finished with status 'done’Successfully installed AstroPrint-1.6.5WARNING: Ignoring invalid distribution -ctolapse (c:\octoprint\venv\lib\site-packages)Done!

And here i where it fails when Octoprint is loading