Connection Problems from Astrobox to Prusa i3 MK3


#21

Previous one doesn’t have flash memory and you had to attach additional board.
At Prusa assembly page you can see images of both:
https://manual.prusa3d.com/Guide/8.+Electronics+assembly+(B3-R2+design)/513?lang=en


#22

witch Board do you have : Version A oder B?


#23

I have:
Version A: LCD connectors are used directly on the EINSY RAMBo board.


#24

ok, thank you. Tonight, I’m gonna check out which board I have.


#25

i also have the version A.
unfortunately the problem with the connection to the printer persists.


#26

I don’t understand where the problem is.


#27

@daniel: I send the logfiles to you


#28

@Brainson. I see this in the logs:

2019-01-24 20:22:53,986 - astroprint.printer.marlin.comm - INFO - Changing printer state from [Offline] to [Connecting]
2019-01-24 20:22:53,987 - astroprint.printer - INFO - Connected to serial port [/dev/ttyACM0] with baudrate [115200]
2019-01-24 20:23:39,138 - astroprint.printer.marlin.comm - INFO - Changing printer state from [Closed] to [Closed with Error: TypeError: 'an integer is required' @ comm.py:_rea...]
2019-01-24 20:23:39,142 - astroprint.printer.marlin.comm - INFO - Changing printer state from [Connecting] to [Closed]

Unfortunately it’s not enough information to know what’s happening. If you enable serial logs, we will get more info. In the same screen where you sent me logs you can do the following:

  1. Clear logs
  2. Enable Serial Logs
  3. Try connecting a couple of times to log the sequence.
  4. Send logs to us again

Thanks for your help.


#29

Okay thank you, I’ll do that tonight… hear you :wink:


#30

logs are on their way…


#31

Got the logs. The printer is not responding at all. We send our probe M105 commands and nothing comes back, eventually we give up.

Are you able to connect to this printer with any other host software?


#32

octoprint works well


#33

do you use any plugins to aid connection with OctoPrint? Also does you printer have any mods?


#34

no, i don’t use plugins


#35

Do you have an SD Card on the prusa when you try to connect with AstroPrint? If so, could you remove it and try again.

Also. We’re looking at another bug that might be related to this. Try changing the baud rate, trying to connect and then changing it back again.


#36

Hello Daniel, yes I have an SD card in the slot, I will remove it tonight and try reconnecting the printer.
I’ve also tried to change the baud rate, does not help.


#37

Update to my update for those who may be reading this with the same problem. I fixed it by removing the SD card, rebooting my printer as well as rebooting the AstroBox AFTER my printer. Not sure if order matters. It might have had to do with the SD card. I also disconnect all usb devices like my keyboard and mouse from it

So I just bought my MK3S!! I’m trying to connect to Astroprint and I’m getting the same issue. Any update on if the issue was fixed and the solution? I have tried every single braud rate especially the 115200 and even reflashed and it’s still not working. 2 hours in and still nothing :frowning:

Just a quick note, when I hit connect on AstroBox, my computer fan spins for a second like if it recognizes a computer was just plugged in. But AstroBox isn’t responding. It has sat in connecting for hours now