Dead in the water after update to v0.1.11


#1

I’m dead in the water after updating to v0.1.11

I did an update from with in AstroBox to the next version of AstroPrint, which loaded v1.11. I did a shutdown and restarted printer and the AsrtroBox. Booted up, everything looks good at first.

  1. I cannot move the extruder using the arrows.
  2. Home works on all axis, so that is good.
  3. I can control the temp of the extruders but not the hot bed. Doesn’t even read the temp.
  4. I get an error saying “cannot access WiFi settings”
  5. Camera works…

So what happened? Why would this not work after a simple update and reboot?

In plugged in my 2nd AstroBox into the printer (I have not updated it) and it all works fine. But I need both printers working…

Please advise!

Thanks!
Scott


#2

I did a factory reset, now I can control everything. But… setting the bed temp to anything besides to off sets it to the max. I run at 50C, and it ties to reach 140C!!! So I set the bed temp max to 50. So that is obviously botched in the new release.

Also when I select a job to run it does not show the heating up screen. So I have no clue when the print job will start.

I see there is a v12 I an load. I’ll try that next.

Arg…


#3

Scott these are not problems we have seen. Where did you get that release from?


#4

Hi Daniel
Thanks for your reply! I simply did an update from within the AstroPrint setting page that served up by the AstroBox via its own hotspot WiFi connection.

Only a factory reset got me going again. Which then I ran into the setting bed temp issue.

The only clue I have to the issue is that I had trouble uploading a g-code file prior to the update… which occurred only once, right after a city wide power outage. So maybe the SD file system is corrupted?

That is the one thing I hate about using Raspberry Pi and Linux for embedded systems. They do not handle instant off/on very well without a lot of work.

Sorry I probably sound like a whiner huh?


#5

Maybe try re-flashing with the image that’s up there now 0.12(1) and see if the problems go away. Corruption does tend to be a problem in some cases.


#6

So I loaded .12(4) and now after typing in 50 degrees for the heated bed, it does nothing. Just sits and spins.


#7

This is perhaps a case of bad connection between the box and browser. Like it’s not receiving the comman acknowledgment. Does the printer actually heats to 50?