Failed to start dhcp server and wifi access point

I have a Raspberry Pi 4 Model B 4GB. I see posts that the 8GB pi4 isn’t yet supported because 64bit isn’t yet supported. The model B has as 64bit processor. Does that mean it isn’t supported even though I have 4GB RAM not 8GB?

Any way, after flashing the SD card and starting up the rpi, I the Astro print never broadcasts its ssid.

Plugged in monitor, and see that at end of boot have two FAILED warnings.

Failed to start LSB: DHCP server
Failed to start LSB: WIFI access point.

Is the problem I am on an unsupported pi or something else?


if the OS boots, that’s not the problem. Very likely you’re missing the WiFi dongle.

the pi4 model b has built in wifi.

“2.4 GHz and 5.0 GHz IEEE 802.11ac wireless”

why would I need a dongle?

The dongle is needed in order to create a hotspot while at the same time connecting to an existing network. The errors you’re getting are related to the creation of the hotspot. If you don’t have a WiFi dongle you can ignore them. Here’s more info regarding how to setup without an dongle:

Thanks. This is working much better. With ethernet connected, I was able to find my astrobox device and connect to it. I setup a printer profile as well. There was a prompt to indicate if I wanted to ‘turn off hotspot if known network is found in future’. I left it checked but should I turn it off?
So I can now disconnect the ethernet cable. Doesn’t the astroprint gw/rpi need to be connected to my network for future printing? I either need to keep the ethernet connected or get the builtin wlan connected to my wifi. Correct? I’m sure that can be done from the command line; I’ve typically done it via gui. Is the OS with the astroprint image setup to enable gui?

You need internet connection via either WiFi of Ethernet. Using the internet connection you can connect the box to your WiFi and while you’re in range, it should auto-connect and you will be able to remove the cable

After following these instructions, I disconnected the ethernet cable and tried setup the wifi connection. I’ve tried with raspi-config and editing the wpa_supplicant file direct. Both techniques have worked flawlessly on another pi4b with the latest raspian OS. On the astroprint image, neither technique results in a connection to the network or an IP address assignment. Please advise.

There’s no need to fiddle with OS configuration . Not sure why you want to go that way but if you must you also have to do this:

I’m confused by your comment. I need the rpi on the network for the gahteway to work. I don’t want to use Ethernet. How am I supposed to connect to WiFi without fiddling with the OS?

Daniel, I appreciate the help given. I followed the last link and I can now connect to my wifi network. I had been following to connect the pi to wifi. Are you saying I shouldn’t have needed to do that and simply just follow Should I have done something altogether different after following the “how do I setup an AstroBox gateway without a dongle hotspot” instructions?

When I follow the printer connect wizard, there’s a checkbox “Turn off hotspot when known network is found in future”. Can you explain that prompt and if I should have it checked or not?

I have the printer connected via USB to my rpi. When I start the astroprint desktop software, the printer shows as ‘Locked’. What does that mean? Do I always need to select the ‘Connect your printer’ button at the top of the window? After clicking the printer, I can click the launch button and it takes me through a setup wizard again. Do I need to do that every time? I’m not clear how to keep the gateway and printer in proper state from here on out.


You shouldn’t need to touch the hotspot button. You should simply:

  • Connect Ethernet
  • Find your printer
  • Open its web ui
  • in there go to settings / network
  • Find and connect to your WiFi.
  • Note the wifi IP address and access the box using it from that point on