HELP with Astroprint Setup


#1

While doing the the Astroprint setup, after a successfull connection to the internet, the next tab is Printer selection instead of connecting to account like in the different instructions i saw. After i press that tab it just is “loading data” for ever. When i open a new browser tab with the 10.10.0.1 it just says “beginn setup” again.
When i first connected to the astrobox to my wifi everything seemed as it should be, i was able to enter the password of my network and connect to it successfully

I tried reflashing the sd multiple times
i tried it on different browser
i tried it with multiple raspberry’s pi 3

The wifi stays the same (astrobox-xxxx)

although as soon as i unplug the astrobox, after that the wifi from the box is not visible anymore, which meant i had to reflash it to start the process all over, but like i said its the same every time.

i just get stuck in this loop

Help would be greatly appreciated, thanks in advance
IMG_6189


#2

Not sure if this is the issue I had but I’ll give it a go.

I setup my astrobox using a network cable to my router. Once I was all setup I unplugged the network cable and I couldn’t connect to the astrobox.

I reconnected the network cable and got connected again, then from the astrobox dashboard had to go into settings to set my networks ssid and password. Then when I disconnected the network cable it would connect to my router.

Like I said, I’m not sure you are describing the same problem but it sounds close. Would be the same if you were using a wireless dongle.


#3

I think its a different Problem, but ill give it a try as soon as get my network cable (had to order one)

Anyway thanks for the quick response :slight_smile:


#4

If you didn’t enter in your network ssid and password somewhere, then it won’t have anyway to connect when you unplug it, or remove the wireless dongle.

Give it a go and see where ya wind up.


#5

Well i did the standard connection procedure setup, where i had to select my network ssid and enter the password. But i did not add a ssh file and add it there. To my knowledge this shouldn’t be necessary though.


#6

No ssh should be required. Can you double check your ssid and pw to more there weren’t any typos?


#7

Yes no typos, i have tried it multiple times. The ssid is just a selection anyways.


#8

What version of Raspbery PI are you running?

What are your wireless network settings? Do you have Mac filtering turned on?


#9

Pi Version 3 B V1.2

What networks setting do you mean?

Mac filtering is turned off

EDIT: Just tried it with a rasp pi model 3 B+, same issue


#10

From the wireless access point what setting are configured on that device for the SSID your trying to connect to? A/B/G/N? WEP/WPA/WPA2?

What brand of AP is it?

From the AP management portal do you see the AstroBox connected?

Is the AstroBox getting a correct IP address with a default gateway and DNS server?


#11

I managed to connect to the asto box via typing in the url to connect it to my account, but i had troubles getting it to work smooth, it was slow and dropped the connection many times, settings did not work as i wanted etc.

I now moved back to octopi and am happy again :stuck_out_tongue:
Just going to use it with the plug in from octopi which is good for now

Thanks for the help though