Help with octoprint plugin!

So I’ve tried to install the astroprint plugin a dozen times, had a few errors the first few times. Finally got a successful install but the astroprint tab never shows up, nor does it join my list of installed plugins. I’ve run the install quite a few times now and can’t quite figure it out.

Any thoughts on things I could try?? I’m quite new to raspberry pi, and octoprint, and astroprint. Any help would be fantastic!!


You are not telling us where you are trying to install anything. Start by describing the system you are using. IS it Cura? or any other slicer?

Sorry, I’m quite new to all of this. I’ll give you the short and curly.

I recently acquired a 3D printer, it’s fantastic!! After watching some youtube I installed a raspberry pi 3B+ running the current octopi.

Now I drag and drop my gcode files into octoprint on my PC. So I am using octoprint.local. When in octoprint I have tried to install the astroprint plugin many times. Both via the plugin manager, and via the downloaded zip file. After some initial errors, it now “says” it installs successfully. After the successful install in the corner of the screen it says “installed unknown” a restart is needed. After the restart there is no astroprint tab, nor is it in my plugin manager.

I’m not sure if it matters any but just in case, I am using the cura desktop app for slicing and saving out gcode files. I have been successfully printing those through the octoprint web interface wirelessly.

Because I am new to all of this and have been poking around, I have discovered I have no idea how to run command line on my raspberry pi. I downloaded putty but it does not accept my login credentials that octoprint accepts.

Hopefully that covers everything. If I have left out any details please let me know.

Thank you so much for all the help!! In reality, the astroprint plugin was the primary reason I wanted a raspberry pi to begin with.

You may want to go the route of installing AstroBox directly onto the Raspberry Pi. It will replace OctoPrint.

May be easier to get started :slight_smile:.

Whoa, slow down for the rookie here.

“It will replace octoprint”… octoprint is just the utility, and octopi is the operating system.

Is Astrobox an operating system that would replace octopi?

Would it be equally easy to hop on a web page or such and drag and drop to print as I’m doing now?

AstroBox will replace Octopi.

You flash AstroBox to the SD card just like you did Octopi (replacing it).

  1. Flash Astrobox to the SD Card

  2. If you don’t have an additional wireless dongle, you can follow these steps to get it connected with a network cable temprorarily.

  3. Complete the setup

  4. After all of the above you will now be able to connect to and you should see your printer. You can slice and print directly from the web.

This sounds like what I should have done in the first place!! It doesn’t sound any harder than getting octopi up and running. Plugging in via ethernet cable to setup the wifi can’t be any harder than editing text files, lol.

A couple questions about astroprint though. Does it have a terminal to execute gcode commands?? I used that in octoprint already to adjust my Esteps to dial in extrusion. I think that’s a feature I’ll be using again.

Also, I have a logitech c270 setup. Would this camera work and if so, is there a utility to flip the image (it’s mounted upside down).

Lastly, octoprint has a really easy to set and forget timelapse function that will create a timelapse of every print once setup. Does astro have something similar??

And thank you once again for the help!! I’m quite thrilled that I’ll be able to use the astro ecosystem. I was completely unaware that they had a raspberry pi operating system freely available. I was only aware of the gateway and touch boxes that you could buy.

AstroBox does have a GCODE terminal, you just need to be on the same network as your AstroBox to access it. You can go to http://astroboxip and it will bring up the local web console.

If the camera was working on Octopi it should work on AstroBox. You can flip the image in the camera settings by connecting to the local web console just like above.

Time lapse wise, there is no way to set it to create time lapses every time automatically that I know of, you will need to click the time lapse option each time.

I could probably live with clicking a button or checking a box to get my timelapse. I’ll just have to add that to the preflight checklist. As long as the functionality to create the timelapse is there then I’ll be a happy camper.

Also, since the information is flowing, with all the cloud stuff…

Can I:
A) Store gcode files on the cloud to start printing via the web or app?
B) Download a design at work and then slice/print via the web or app?

A) You can store files in the cloud, free version includes 2GB of files
B) Thingiverse and MyMiniFactory have apps on that you can connect and upload and print files right from a web browser.

This is all fantastic. In between jobs today I stopped home and installed astro on my raspberry. Got everything working quite quickly and started a job via the web interface before I took off to work.

Tried the app and the still images came through great!! I was however unable to get the video to play while at work. Maybe it’s a corporate network thing? Should I normally be able to pull it up via chrome and watch the video?? I was having it record a time lapse, does that make a difference??

In any event, I’m very grateful for the help I’ve received. I already love the interface. The ability to browse thingiverse and mymini right from the we interface and shove files into my folder is great. I’m already contemplating getting a touch screen just for grins.

Any help on the video bit would be fantastic. But again, thank you very much for the help.

It’s possible that your corportate network is blocking the WebRTC connection that we need to delivery video. For this reason we allow you to take photos at any time. This should work from any network

I think you are right. I literally just got to work (my other job), and the video works like a peach here. It must be the network restrictions at the other job. Photos do pretty swell to stay informed as to how a print is doing for me, it’s a simple click to refresh it.

Thanks for chiming in, I’m really impressed with astro so far. A few little confusing things with the interfaces but I’m printing, and running remote video so it’s all well and good. I’ll figure out the little things as I go.