Logitech c270 Not working at all

Due to covid-19, all of the recommended cameras are either out of stock or 3-4x what they typically cost. I was able to find a c270 still new in box - and although it’s not in the list, there are other forum posts where users claim that it should work.

I have an Astrobox (not touch), running 0.18(0). Everything works for printing - movement, linking to Astroprint.com and the Astroprint app. When I connect the camera and power cycle the astrobox, the box shows that the camera is connected, although there is no image. When I attempt to switch to live video or take a still image (via the app or web), I see the light on the front of the camera activate as if it’s taking a photo / video, but I get an error in the app saying that there is an issue with the camera and I should make sure that my astrobox is up to date.

Since it is up to date, is there anything else i can do other than buy another camera? I’ve tried moving the camera to different USB ports on the astrobox, i’ve tried connecting the camera with the box off and while it’s running.

Have you tried modifying the resolution in the settings?

Kirby -

Thank you so much for responding. Yes, I’ve tried all the settings available within the Astrobox settings page. It currently recognizes the camera as a “USB Camera” and the default image resolution was set to 640x480, h264 encoding.

I have tried multiple different combinations of video stream encoding and resolution to see if I could get a picture at all, but was unsuccessful. The camera itself is confirmed working, as i’ve used it for both still and video while plugged into my computer.

Ahhhhh I see. Can you find another use for this camera? I’d honestly recommend getting a Wyze cam from Amazon or Wyze’s website. They’re $20 a pop, and you can flash its firmware to be a webcam so that it works with AstroPrint or leave it as is and use the Wyze app (which I HIGHLY recommend, it has a great timelapse feature.)

Other users have reported similar problems. The camera isn’t compatible unfortunately. I have also updated the camera compatibility article to reflect this.