No devices connected! No remote connection!

The last two days, I have been unable to print from or the astroprint app. When I try to print, I get a “No remote connection” from the cloud or “No devices connected” from the app. I have restarted the astrobox service on the pi, rebooted the pi, restarted my router…all to no avail. Interestingly, I can select the printer from the app and use the extruder control to move it up and down, so the software does have a connection to my printer then, right? I cannot do the same with the monitor function from the cloud UI. I have also just now run an apt update/upgrade to make sure the pi was up to date. That didn’t help. I can’t think of anything in the environment that would have changed. Any suggestions?

The app should now work.

Also devices were disconnect and users logged out by an unfortunate server issue. You should be able to reconnect by going to your astrobox web Ui or via your touch interface. There you can re-login by clicking on the red rocket.

unfortunately, it is still not working for me. I have logged out/in from both interfaces and rebooted pi and I still get the same error messages.

We have a fix for the reconnect issue. It’s in the Beta channel, you can update your AstroBoxes to version 0.19(1) which contains this fix. Be aware thought that it’s still beta software so we recommend that you don’t update yet for mission critical applications and if you have more than 1 controller, only update one.


What’s the ETA for releasing a production version of the fix. I too have had problems over the last few days with Astroboxes disconnecting overnight.

can you please point me to the beta channel? I looked at the various forums and didn’t see one for betas. I have the same question as Rainer_Fuchs on expected release of the fix into production.

In your astrobox UI, go to settings / software / advanced. There you can change the release channel of your astrobox

I don’t see that path from either the or AstroPrint ios app. I have the astrobox software on a raspberry pi…not one of the purchased Astroboxes. Can you please indicate again from either of the UIs I have access to, a path that will get me functional again? I am not able to connect to my printer from either UI.

This can be found in neither of those places. This is part of the AstroBox Web UI which can be accessed via its IP address