pcDuino AstroBox setup


#1

Bought an astroprint with the original kickstarter; I believe it’s a V2
Finally have a printer setup and went to do the setup.

Plugged it in
Connected to its wifi
Setup for my wifi

Then I couldn’t login thru 10.10.0.1 on my phone, tried to access it from my desktop and after “logging” in on the printer it’s not responsive. Not sure what to do. Off/on and reset doesn’t seem to do much. If I let it sit there it appears to recycle on/off on my printer itself.

Any ideas?


#2

Ok so after I got it setup I was able to get into it thru my phone (10.10.0.1) on it’s built in wifi, and I could move my printer around. Cool but couldn’t login to link it to my astroprint account.

I hooked the box up to my monitor (no printer attached) and this is what I got…
Any ideas?


#3

Before that screen it sat at this one for a while.


#4

Hi @Adam3, Note that this hardware is 4 yrs old and was discontinued in favor of the Raspberry Pi based AstroBox. We no longer support it.

The software ( including its OS ) is very old.


#5

Well that kinda sucks don’t it.
I’m slow on projects but I guess I put it off too far.
It was cool running the printer around from the phone for a few minutes. Is there no way to try and get it running at least a little bit?

Is there a “last” update firmware or anything?


#6

I don’t mean to be gruff about this; but I did put money ($75) in at the time of kickstarter because I believed in the project and hope I can get a bit more service than “it’s old and we don’t support it”


#7

Could you also tell me how I can claim my Pro Plan that was part of the kickstarter? Thank you.


#8

Contact us on https://astroprint.zendesk.com with your backer number and your astroprint account email. We will activate the Pro Plan for you.

We appreciate your support in Kickstarter but the product is 4 yrs old. We have supported that hardware until a few months ago but unfortunately had to discontinue to focus on the Raspberry Pi as we can’t do everything with a small team. If you have a raspberry pi laying around, you can simply install this software here: https://www.astroprint.com/downloads


#9

I learned some linux ,hooked it up, got it to delete the bad wifi connection. Reboot reenabled hot spot. Now I’m back able to control it with my phone. But still no ability to login. Is an account now no longer able to work with an existing V2? I notice its on 0.2 and can’t be updated.
Despite you not being able to “help”, are you able to provide the most recent version you did get to? 1.x? or Whatever it would be?
I understand small team and all. I’ve ordered a ras pi 3+, I’ll be looking forward to working on that and I’ll email your guys about the backer thing to get my account setup.

A little more info would help though, I’m just trying to see what I can do with this $75 brick otherwise. Yes phone connection over wifi is great, but being able to actually use the online account would be great-er.


#10

Here’s what you can do. Run these commands in the command line.

sudo apt-get update
sudo apt-get dist-upgrade
wget https://releases.astroprint.com/13193d7c50c6461dbb1e8f747d87d006.deb
sudo dpkg -i 13193d7c50c6461dbb1e8f747d87d006.deb
rm 13193d7c50c6461dbb1e8f747d87d006.deb
sudo reboot

You might also want to update the file at /etc/astrobox/last_known_time to 2018-09-01 00:00:00 before reboot.

I hope this works. This is all we can offer at the moment for this unit.