Plugin not loading


#1

I’ve just installed the OctoPi Astroprint plugin and it’s not loading.

In the log I’m getting the following, Any thoughts?

2018-01-04 18:27:36,590 - octoprint.plugin.core - ERROR - Error loading plugin astroprint
Traceback (most recent call last):
File “/home/pi/oprint/local/lib/python2.7/site-packages/OctoPrint-1.3.6-py2.7.egg/octoprint/plugin/core.py”, line 732, in _import_plugin
instance = imp.load_module(key, f, filename, description)
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/init.py”, line 9, in
from .AstroprintCloud import AstroprintCloud
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/AstroprintCloud.py”, line 12, in
from .downloadmanager import DownloadManager
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/downloadmanager/init.py”, line 10, in
from octoprint_astroprint.AstroprintDB import AstroprintPrintFile
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/init.py”, line 9, in
from .AstroprintCloud import AstroprintCloud
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/AstroprintCloud.py”, line 13, in
from .boxrouter import boxrouterManager
File “/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_astroprint/boxrouter/init.py”, line 22, in
from ws4py.client.threadedclient import WebSocketClient
ImportError: cannot import name WebSocketClient


#2

You’re missing the ws4py package. Possibly due to an incomplete installation.

You can fix this in the command line by running:

sudo pip install 'ws4py==0.3.4' --force-reinstall

#3

Ok. Tried that same issue.

Also tried uninstalling the astroprint package and ws4py and re-installing. still get cannot import name Web SocketClient.

“sudo pip install ‘ws4py==0.3.4’ --force-reinstall” now gives

Requirement already satisfied: ws4py==0.3.4 in /usr/local/lib/python2.7/dist-packages


#4

Not really sure then. It’s possible that installation is now corrupted somehow. Are you able to completely remove and install again?


#5

Ok I’ll have to do a clean install then I guess.


#6

Yes, unfortunately. Let me know how it goes