Print failed to start, Unable to start download process


I have suddenly started to get this error when attempting to start a print. I’ve tried updating my box but get an “error checking for new software”. This box was previously working fine. Any ideas?


This indicates a problem at the box. It can’t properly communicate with printer. Perhaps DNS resolution


If it was a DNS issue I wouldn’t expect any contact with the printer would i? I can still control the print head and see the temp from teh monitor panel. Can also log into the box and upload gcode direct.


All of that is done via a different channel and/or direct connection via local network.

What you described before is consistent with network problems reaching our servers. DNS is the most common


I am still unable to print to this device over the web portal. I have checked in my router and the box appears normal along all my other devices. Only the astrobox is having issues. No other devices on my network have issues. What steps do you recommend to fix your device?


Ok. let’s get some logs so we can see what might be going on. You can go to Settings -> Software -> Advanced and clear logs. Then make the problem happen and send logs to us so we can see if there’s an error reported by the box.

We can go from there.


Ok just tried, says “there was a problem sending your logs”… earlier I tried deleting my network and setting it up again but that didn’t seem to help. Would reflashing the firmware possibly reset whatever is going on?


Yes, possibly but I would like to know what’s going on if possible. Are you able to SSH into the device ( ). If so please run this

cat /var/log/astrobox/astrobox.log


Any word on what was going on? I am also unable to print. I’m getting the message “Your print failed to start, please try again. Unable to start download process” after slicing.

There are no new entries in /var/log/astrobox/astrobox.log after I try to print the file.

I was able to successfully send my logs.


Well, I just discovered that for some reason it defaulted to X3G instead of gcode. I changed it and now it is working…


I am now unable to print. when i try i get the notification saying print failed to start. any idea on how to fix this?
I cant get to my settings to clear logs? how do i clear logs?