Print finishes but Astrobox doesn't think so

This is odd…I am using a new home-brew printer…this time with marlin vs repetier on my previous setup.
my Astrobox worked fine on the other machine and if fact works ok with the new one but I am doing things differently and have a problem at the very end of the process…

I slice using Cura (full desktop version previously I used cloud slicer and I have’t tried that with this machine yet) I upload the G-code to astroprint cloud then using my astrobox I start the print…either from the box itself or from a computer connected via the web…the print completes and everything seems to happen with the end code running to cool the hotend and bed and final positioning but the astrobox thinks it is still printing…on the last layer…it is like the last layer never finished. Maybe there is something missed in the setup of this new system…something that tells astrobox the print is done? Seems like it drives the printer and should know the last commands have been sent but maybe it is waiting for some confirmation or some final instruction is not actually sent but the printer has stopped listening…


The result is I have to cancel each print then close the 'Why" prompt then I can continue…communication with the printer seems solid as does the astrobox power…I don’t loose control on connection to the printer just need to cancel the print and go on.

There’s very likely an error. you should activated serial logs and download the serial.log to inspect for any errors towards the end of the print