Printer freezes up after starting print


#1

This is kind of a follow-up thread to this one.

I got the Astrobox set up, and the pinter connected after using @Daniel’s tip.
I can heat everything up, move all 3 axis, and control the fan. But as soon as I start a new print, the printer’s controls freeze up, before the extruder even heats up. The “Printer Controls” stop working, but I’m still getting the current temp of both the bed and extruder.

Here’s all the useful info I can think of:

Start Commands:
M104 S{print_temperature}; set the extruder temp and wait
M109 S[extruder0_temperature] ; set extruder temperature and wait for temp
M140 S{print_bed_temperature}
;M190 S[bed0_temperature] ; Wait for Bed Temperature
G28 ; home all axes
M190 S{print_bed_temperature} ; set the extruder temp and wait
M109 S{print_temperature}
G80 ; Probe
G1 Z5 F5000 ; lift nozzle

Temp Slic3r Settings:
Ext. Temp(first and other layers): 185
Bed. Temp(first and other layers): 40 (Was 0, changed to 40 to check if that’s the problem)

Thanks a lot!


#2

This is most likely causing the problem. Change that to:

M109 S{print_temperature}

#3

Okay. Thanks! Will try when I get home.

On another note; I saw that the fix I used for the Prusa will not be needed anymore, in the next update. When the update is released should I change the config.yaml back?


#4

@Daniel, here’s an update:
The problem might be with the start script. I tried messing with it, and noticed the printer keeps sending temperature info to the Astrobox.
When I start my print the printer doesn’t respond to the commands it gets from the Astrobox, but it’s still sending temperatures and all. After a while, it disconnects fully. Even after canceling the print, the printer won’t respond, so I have to restart the Astrobox for it to work.

EDIT: I tried adding a “G28 ; home all axes” before the first line in the GCode. It now looks like this:

G28 ; home all axes
M104 S{print_temperature}; set the extruder temp and wait
M109 S{print_temperature}
M140 S{print_bed_temperature}
;M190 S{print_bed_temperature} ; Wait for Bed Temperature
G28 ; home all axes
M190 S{print_bed_temperature} ; set the extruder temp and wait
M109 S{print_temperature}
G80 ; Probe
G1 Z5 F5000 ; lift nozzle

The homing GCode executes, but M104 doesn’t.


#5

Could you try changing the slicer to Cura in the advanced section of your printer profile?


#6

@Daniel thanks a lot! I changed to Cura, and now the printer finally prints.
BUT! it uses the wrong temperatures. Extruder is set to 185, and bed to 40, but prints start with 210 for ext. and 70 for bed.

I dug around the settings, and everything seems to be set correctly on the Astrobox itself.

EDIT:
Fixed the problem. Everything’s working!
Switched back to Slic3r, from Cura. Used this script:

M104 S[temperature] ; set the extruder temp and wait
M140 S[bed_temperature]
G28 ; home all axes
M190 S[bed_temperature] ; set the extruder temp and wait
M109 S[temperature]
G80 ; Probe
G1 Z5 F5000 ; lift nozzle

The problem seemed to be M190 and M104.


#7

Check your material settings for the material you selected. What temperatures is it set at?


#8

Sorry for the long wait @Daniel!
It’s set at 185, PLA.


#9

Does it also say that when you look at the settings used for your print file? You can click on the settings link next to the material on your print file list to see this.


#10

Yup. Shows the right temperatures.


#11

The last think to check is downloading the GCODE generated by AstroPrint and check if the following lines properly added the right temperatures:

M104 S[temperature] ; set the extruder temp and wait
M140 S[bed_temperature]
G28 ; home all axes
M190 S[bed_temperature] ; set the extruder temp and wait
M109 S[temperature]