Printer (Monoprice) connection issue (Raspberry Pi) & Fix


#1

Just wanted to share a what I went through trying to connect to Astroprint …

I have a Monoprice Select v2.1 and was hooking up a Raspberry Pi 3 with Astroprint and could NOT get it to connect.

I had played around with this before in connecting to the IIP “Cura” software that came with the printer. That would NOT connect no matter how many chicken feathers I spread in a fairy circle at midnight - LOL! Being a Computer & Electronics Tech, you can be assured all avenues were tried…

HOWEVER - I was able to connect to Repetier-Host and MatterControl. I found with them that the BAUD RATE setting in the control box had to be set to 115200, as you noted. Then they worked fine.

Enter ASTROPRINT. I followed the setup for the Raspberry PI 3 and all went fairly well. I did have the {known} “can’t use the built in WiFi” issue, so I hooked up Ethernet (had a spare line in the room). I then setup my Router to assign a fixed IP address (not explained here …) and went to that address. TADA! Connected!

I then finished the Astroprint setup from my PC which went fine, UNTIL it tried to connect to my Monoprice. NO JOY!

After a couple minutes of playing around trying to follow various troubleshooting instructions, I found one on Astroprint’s site, that was from a while back, where they mentioned they had updated their site’s Security Certificates. I then said “Ah-HAH! I KNOW WHAT’S WRONG!

As a Computer Tech I’ve run into this occasionally over the years. On older PC’s, or if the owner was screwing around, the CLOCK on the PC gets set for a wrong date. If it’s older than a year, or set into the FUTURE, if you try to connect to a secure site it will fail, since the PC looks at the DATE of the site’s Security Certificate and look to see if it’s EXPIRED. Since the PC has the WRONG date itself, it will think the Cert is EXPIRED and refuse to connect!! Auto update of Date & Time in a PC ONLY works if the date & time are CLOSE to correct, if wildly off, the Auto Date function FAILS, so the PC will be stuck thinking it’s like 1999 or something :slight_smile: . Since the Cert is dated 2017 … it thinks’ it’s a bad Cert.

I suspected the Pi was refusing the connection from Astroprint because it’s date was wrong!

I went to the Raspberry Pi, and logged in (Default name = Pi , Password = raspberry) .

I ran the config program and corrected the Keyboard, Locale and Time Zone (the Pi is defaulted to UK, since it’s made there; I’m in the US East Coast). The command is:

sudo raspi-config then (no spaces), but:

Here’s a well written post from StackOverflow :
This is how it works:

  1. sudo raspi-config
  2. Internationalization options
  3. Change Time Zone
  4. Select geographical area
  5. Select city or region
  6. (PUTERPRO ADDS) I would ALSO fix the Keyboard while I was in the config setup, before reboot.
  7. Reboot your pi

Once you reboot, sign in again and set the date:

sudo date -s “Jul 27 13:00:00 2017” (the –s mean “set”)

Now, I personally used sudo –s 07-27-2017 13:00:00 , so that format works as well.
(it’s a 24 hour clock so 1pm = 13:00, and of course put in your current day & correct time … duh)

Just entering “date” (no quotes) will display the current date. You can change just the time like this:
date –s 14:27:00 Sets the time to 2:47pm.

After entering the proper date & time I rebooted my Pi and VOILA! It connected to Astroprint!! YEA!!

BTW- if you keep it connected to the Internet, it auto updates the date & time from now on (at least on the Raspberry Pi 3, not sure on earlier models, I’m a n00b at the Pi.

Hope this helps someone …
PuterPro


Maker Select v2 Connection Problems