Random Disconnect from Printer

Hello all,
I have a Robo 3D R1+ that I control with a Raspberry Pi. Everything was working great until about a week ago.

Now when I try to set up the printer for a print I will up-load the G-code (saved from simplify 3D). I will preheat the extruder and the bed. I will then extrude 10-50 mm of filiment to ensure the extruder is working and then I will start the print. At random times during the process I will get an error message to connect a printer via USB even though the printer was connected just a second ago. Sometimes I have been able to get the printer to go though the entire leveling process and then on the monitoring of the print it shows that the print is running even though the 3D printer is not doing anything.
I have done the following:
Turned off everything and let it sit for 10 min.
Turned on the printer and wait 10 min.
Plug in the Pi and wait 10 min.
Load astrobox and set up the print

I have also downloaded .11(22) and re-flashed my sd card with the software and it is still happening. If anyone has any ideas I would be great-full.

Thank you,

Look at this for clues: https://astroprint.zendesk.com/hc/en-us/articles/115001797403-Why-does-my-printer-disconnect-in-the-middle-of-a-print-

Also try with other external hosts like Cura for example in case there’s something wrong with the printer board or maybe a new firmware version?


Thank you for the info. I have looked at and tried some things this morning. So a little background. I am new to 3D printing. We received our printer around thanksgiving last year. We set up the pi about a month later. We have been running successful prints though the astroprint and the pi and have been having a lot of fun.

The power supply for the pi meets the minimum standard from the article. The usb cable is the same one we have been using since we bought the printer and pi. It has the bead and there is no damage and it is routed properly.

Only the software for the Pi downloaded from the site is installed.

The controller boards I am not sure how to check. I can troubleshoot if steered in the right direction as I have a background in troubleshooting electronic equipment.

I have not turned on the logs. That will be my next step.

Some things I have discovered.

  1. I tried running a print from the desktop version of astro print connected via usb. Even though the print didn’t work (homing and leveling issue/z axis issue) the printer didn’t disconnect the entire time I was getting the print set up and even when I started the print. I don’t know how to fix the z axis issue though the desktop version.

  2. After I saw how the printer was doing I stopped the print, disconnected the printer. restarted my pi without the wifi usb dongle. The pi would not connect. I inserted the wifi usb dongle the pi connected. I have not had to have the wifi dongle in place for the pi to connect to wifi before. I don’t know if there is an issue with the new software or if there is an issue with the wifi on the pi itself.

once i had the wifi dongle installed the pi came up but it started having the disconnect issues again.

I will try to turn on the logs and update once done.

So here is an update.

A friend was helping me to troubleshoot. During the process I connected the printer directly to my laptop and loaded up a file in simplify 3D. As the extruder was heating up it just stopped and started to cool. I looked at the code that was open in the box and saw the following error:

READ: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
READ: echo: cold extrusion prevented
cold extrusion prevented
READ: Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

I checked the wires going to the extruder and found that some of the bare wires were exposed. I pushed back the wire covering to ensure the wires were not shorting. I tried to print again but got the same error.

What would be my next steps?

Thanks for the help.