Raspi cam stream - astrobox v .10(07)

Hi there,

I have a 1080p Camera with IR running successfully in both images and stream to devices prior to the latest release. Images are coming over ok in the new release, however the H264 (only option for RASPICAM) is now not functioning.
I have reimaged, up[dated and rinsed and repeated a number of times with no success, so there must be something missing in the build.

1 Like

Please use FireFox. The last two versions of Chrome has broken something on WebRTC / H264 combination.

More info on live stream compatibility: https://astroprint.zendesk.com/hc/en-us/articles/209139946-Browser-support-for-AstroBox-Live-Streaming

1 Like

Hi all, unfortunately I have the same issue :confused: Tried with firefox, still not working.

Any suggestions please ?

Hey there,

Well I can say that FF does work. But after an update, I usually do A) a reset of the RPI ASTRO Image then, B) Sudo Update

Then go from there and for me this works and I have done this for each update. But Dan may set me straight on what I really should be doing?

Hope this helps.

Still not working from my side :confused:

Hey there,

Does taking a picture work? Also can you take a photo of your RASPICAM setup so that it is easier to see perhaps from a physical perspective what the issue may be?

Hi all, I am very sry, unfortunatley, I just found out that the camera sensor is defective :confused: Will get back to you when the new rpi camera arrives.

Hey Josef,

Don’t be sorry, it happened to me too. And the RPI attachment for a camera is really poor considering the fragility. It really should be just be a molex plug or mini usb. See how you go :slight_smile:

I am having a similar issue. I am running a Pi 0 W. Everything is working very well except for video from the raspicam. I am able to take stills, but not video. Having the same problem with firefox and chrome and android browser (samsung).

I have not tried FF and will tonight but the camera issue is one I am having as well. Both RaspiCAM and usb both have this issue

Hey Tim,

Can you see if Firefox from a PC shows video? I think Tablet builds on Android have issues but I am not entirely certain.

I apologize, I should have clarified to begin with. I tried on firefox on PC (vers. 52.0.2 32bit). I only tried the android after everything else failed.

Well I am going to go out on a limb here and I’d guess that at least perhaps the on board camera device is not enabled from “sudo raspi-config” use terminal to log onto the Pi and look under enablng peripherals (I think), reboot “sudo reboot” and see if that works…

Sorry, I have already done that. Like I said, I can get stills just not “live” video. I have moved over to octoprint and not having any issues, but I really like the astroprint interface. Video has been the point that makes or breaks it for me. Who can resist the hypnosis accompanied by watching their ideas come to life?

@Tim_workman if the video that octoprint offers is enough for you ( local network only ) you can do this to still use astroprint: https://astroprint.zendesk.com/hc/en-us/articles/216985186-Alternative-Camera-System-for-Raspberry-Pi

Our video system is designed to work over the internet and not only on your local network. For this we have to use WebRTC which is still not very widely adopted and changing. This is the reason why things don’t work on some browsers. More info here: https://astroprint.zendesk.com/hc/en-us/articles/209139946-Browser-support-for-AstroBox-Live-Streaming

The problem with the raspicam is that it can only do H.264 video without using a lot of resources and that video encoding is the least supported by WebRTC. We’re working on improvements but in the mean time you can resort to octoprint-like local network only video with the instructions I posted above.

I’m in the same boat as Tim. My raspicam will take pictures but not live video. I don’t want to go through the hassle of getting it to work on local because I really only want to watch video while I’m away. I will just wait and hope this is fixed in an update.

What browser and device are you trying to see video on?

I was using Microsoft Edge. I just found that Chrome works. Thanks!

1 Like

Im using RasPi B+ with Raspberry Pi Cam, not able to show video or take still from Astroprint.(Latest Ver)

If I SSH and use command > raspistill -v -o test.jpg it takes a still…

What can I do, besides Alternative Method to make this work?

Thanks for any help!


I have pi 4 and pi cam v2 and I can only set 720p. How do I set 1080p? thanks