RPI won't connect to known wifi on reboot


#1

Every time I switch my Raspberry Pi 3 off and on again, I have to go onto the hotspot, remove my wifi router from the known network, re-add it back on and then it works again until I shut it down again. How to fix?


#2

I haven’t seen this before. Please open a ticket with us at https://astroprint.zendesk.com and send us logs via Settings / Software / Advanced.


#3

I was experiencing an identical problem since updating my AstroBox to 0.13(11). I cannot remember which version that I updated from but I also noticed that ssh is now disabled by default.

I resolved the issue after logging into the terminal and running iwconfig to determine the MAC address for the onboard wifi interface of the RasPi. After reserving the MAC address in my router and removing the dongle, I have had no further internet connection issues.