[SOLVED] 5 in. Unsupported TouchScreen not working

In my rush to build an AstroBox Touch, I ended up buying a touchscreen that wasn’t supported. I just saw “Kuman” and 5 inch and I thought I was covered. Ok, I was too excited since I couldn’t get the AstroPrint plugin on OctoPrint to work consistently. I should have probably tried the box-id hack, but didn’t find that until after I decided to build the ABT.

Touchscreen Purchased: Kuman 5 inch Resistive Touchscreen

Similar Model: Longrunner Raspberry-Pi Touch Screen

To be clear, I didn’t get this model: Waveshare Resistive Resolution Interface

I originally downloaded the AstroBox Gateway software by mistake and tried to get the AstroBox Touch functionality working. So, finally after downloading the right image file and flashing the ABT image I was able to get the unsupported touchscreen working.


  1. RTFM Here.

  2. Enable ssh Here. After logging in via ssh, remember to change the default password for the pi user (default password: raspberry). Use the passwd command after logging in. Don’t forget this password. The new password should be used when logging in over ssh.

  3. The kuman 5in. touchscreen wasn’t working with the default setup. Had to edit /boot/.astrobox/astrobox-config.conf.

    sudo nano /boot/.astrobox/astrobox-config.conf Edit file to contain the following:

    Make sure there are no extra spaces around the = signs. I had originally edited the astrobox-config.conf file on my SD card to contain the 800x480 resolution and hdmi driver, but for some reason the file was overwritten on first boot (was replaced with the 3.5 in waveshare driver).

  4. Finish Editing the file.
    Ctrl+X to request to exit nano.
    Y to answer yes to save.
    ENTER to save as the same filename (astrobox-config.conf)

  5. Reboot
    sudo shutdown -r now

  6. If the touchscreen is working, then great! You’re done!
    Otherwise you may have to ssh back into the box and run the configuration script.
    sudo /etc/astrobox/initial-scripts/10-configure-screen

At this point you should now be able to see the touchscreen working. Make sure the rear switch on the display is in the on (up) position. I didn’t have to load the drivers from the manufacturer.

I hope this helps other people that couldn’t quite deal with the small 3.5in. touchscreen who also failed to read the entire product description for supported screens like I did. The ABT is alive and well! Everything seems to be working.
Original message left here just in case drivers need to be downloaded for similar model touchscreens. Enjoy!

Edited for other users who may buy a similar model touchscreen
Original Message Below

Current Situation: Unfortunately I don’t have screenshots yet. I’ve got the touchscreen showing the Pi bootup screen. The rest of the ABT is accessible from my phone, other computers and other devices. I’m just trying to get the touchscreen to work 1) because I’m a stubborn completionist, and 2) I was hoping to document the process here just in case anyone else had the misfortune of buying a similar unsupported touchscreen. Video seems to be working, but I only get a screen with text at the bottom that says:

Raspbian GNU/Linux 9 astrobox-#### tty1
astrobox-#### login:

So it does look like I’ve got the video drivers to work but I had to hack a few things.

  1. enable ssh

  2. I had to mkdir /usr/share/X11/xorg.conf.d (directory didn’t previously exist). Step 3 below wouldn’t complete without errors, because the directory didn’t exist.

  3. Installed the drivers recommended from users online.
    git clone https://github.com/goodtft/LCD-show.git
    chmod -R 755 LCD-show
    cd LCD-show/
    sudo ./LCD5-show

    Drivers are also available from here.

  4. Tried all types of settings in /boot/.,astrobox/astrobox-config.conf
    SCREEN_SIZE=5 or 800x480
    SCREEN_DRIVER=hdmi or waveshare35b_r1, waveshare35b_r2, waveshare35a (tried these just in case I could get the 3.5 TFT drivers to work)

  5. Tried running 10-configure-screen from /etc/astrobox/initial-scripts but it doesn’t exist.
    All I’ve got is 40-raspicam, 50-mf-setup and 60-default-name

  6. Tried looking for obvious errors in /var/log and /var/log/astrobox but haven’t found anything glaring that points to drivers not configured or errors regarding devices

  7. Have not tried requesting another license and restarting.

In any case, any assistance would be greatly appreciated.


It could be that because of the way I installed or because of the hardware I installed, it went ahead with the AstroBox Gateway. Or it could have been pilot error and I installed the wrong firmware. Investigating…

Thanks to previous posters @Daniel, @vlaine

It seems to me that you have flashed the wrong image. What is the file name of the image you flashed

I believe I installed the wrong image now.


I may need to request a new license and lid file after flashing the correct image.

Pilot error.