[SOLVED] Anet A6 disable heatbed and extruder when print is done


#1

I am running an Anet A6 and octopi with the astroprint plugin. The heat bed and extruder do not shut off after my print is done. How can I disable the heatbed and extruder after my print finishes (octopi normally does this when you print from it’s interface)??


#2

The AstroPrint plugin does not interfere with the printing functions of OctoPrint, we merely report to your cloud account on progress. Check your OctoPrint settings.


#3

I have/had the same issue on an Anet A8, using OctoPrint with the plugin.

I think I have solved it by editing the printer setup in AstroPrint, go to advanced settings and in the End Command add:
M104 S0 ;Extruder temp 0
M140 S0 ;Bed temp 0

Not entirely sure that this works as it should, since I’m doing the first print since I did the change right now.
Can write an update in the morning. :smiley:


#4

Well, no immediate success, since it doesn’t look like it honors the end command.
Will try to resolve this and update the thread.


#5

Doh!
It works perfectly, if you generate the printfile/gcode after that you have updated the printer configuration…


#6

Thanks for the tip Markus I can confirm this fixes the issue for me!