[SOLVED] Anet A8 Skynet2.3.2 Prints not centered (X-10 Y-10)


#1

Hi all, firstly i’m new here… secondly this is driving me mad

Just upgraded the firmware on my Anet A8 so i can use G29 auto bed levelling (with a ROKU sensor). I am also now using a E3D v6 hot end… (can you even call this an Anet A8 any more??) Before this the stock Anet A8 firmware works great…

edit should also add i’m using the front left mounting for the ROKU sensor using this E3D v6 mounting from Thingiverse
AND i saw that i needed to use the front left 18mm configuration file for Skynet v2.3.2


I have it basically working with Cura… Home is the middle of the bed, auto leveling works, printing is slightly off centre but ok - can’t actually figure out why it’s off by 20mm in both X any Y… but i digress

Switching to Astro Print… everything starts fine - using the control, horizontal home is bottom left NOT centre, vertical home is dead centre (at the sensor - X118 Y126 Z10) and then G29 auto level works - although there is no readout of the result…

BUT then the actual printing starts at X-10 Y-10… in the bottom left hand corner of the bed, going off the bed. i cannot find a way to fix this, even forcing a G1 X88 Y126 (actual nozzle centre position)

edit using the GCode Terminal

G28 gives me this

X:118.00 Y:126.00 Z:10.00 E:43.74 Count X:11800 Y:12600 Z:4000

G29 gives me this - yes it’s bad but i have a new build plate ordered!

Bed Level Correction Matrix:
+0.999999 +0.000000 +0.001215
+0.000007 +0.999981 -0.006105
-0.001215 +0.006105 +0.999981
X:201.01 Y:185.94 Z:10.68 E:43.74 Count X:20100 Y:18600 Z:4000

I’ve tried changing the ‘bed is centre’ toggle in the printer settings… seems to do nothing.

This has to be something with the Firmware… as Cura works, AstroPrint is conflicting. I have no issue changing the settings using Arduino, but i’m not sure what to change

Any help would be most appreciated

Cheers in advance


#2

Just to add… here is the G Code that i’m using

Gets the Nozzle absolutely centre on the bed…and then it moves when printing starts

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
; Print time: {print_time}
;Filament used: {filament_amount}m {filament_weight}g
;Filament cost: {filament_cost}
T0
M140 S{print_bed_temperature} ; pre-heat bed
M117 Heating Bed… ; Put message on LCD screen
M190 S{print_bed_temperature} ;heat bed and wait
M117 Heating Extuder… ; Put message on LCD screen
M109 S{print_temperature} ;pre-heat extruder and wait
G91 ; relative positioning
G1 Z5 ; move Z up 5mm before homing x/y
G90 ; absolute positioning
M117 Homing… ; Put message on LCD screen
G28 ;Autohome to X0, Y0, then Z0
G29 ; Probe bed
G21 ; metric values
M107 ; start with the fan off
G1 Z10.0 F{travel_speed} ;move the nozzle up 10mm
G28 ;Auto home again
G1 X88 Y126 Z-0.6
G92 E0 ;zero the extruded length
G1 F200 E10 ; extrude 10mm of feed stock
G92 E0 ; zero the extruded length again
G1 F{travel_speed}
; Put printing message on LCD screen
M117 Printing…


#3

Does your current firmware sets the center of the bed to be 0,0 ?

If so there’s a toggle for this unde advanced settings


#4

Daniel

I already tried this toggle… seems to do nothing. But yes the firmware states the bed centre is at 0,0… which is sort of implied by the home function on both Cura and AstroPrint

Any other suggestions??

Cheers


#5

Could you share the first few lines of your generated GCODE file?


#6

@Daniel

Sorry for the delay… here is the first part of my GCode… you can see that it’s decided to go to X-11…

If I added a G92 code tonight to force the centre of the bed would that help??

Cheers

;Generated with Cura_SteamEngine 15.04.6
;Sliced at: Sun 15-10-2017 13:04:12
;Basic settings: Layer height: 0.2 Walls: 0.8 Fill: 0
; Print time: #P_TIME#
;Filament used: #F_AMNT#m #F_WGHT#g
;Filament cost: #F_COST#
T0
M140 S0 ; pre-heat bed
G91 ; relative positioning
G1 Z5 ; move Z up 5mm before homing x/y
G90 ; absolute positioning
M117 Homing… ; Put message on LCD screen
G28 ;Autohome to X0, Y0, then Z0
G29 ; Probe bed
G21 ; metric values
M107 ; start with the fan off
G1 Z10.0 F9000 ;move the nozzle up 10mm
G28 ;Auto home again
G1 X88 Y126 Z-0.6
M117 Heating Bed… ; Put message on LCD screen
M190 S0 ;heat bed and wait
M117 Heating Extuder… ; Put message on LCD screen
M109 S200 ;pre-heat extruder and wait
G92 E0 ;zero the extruded length
G1 F200 E10 ; extrude 10mm of feed stock
G92 E0 ; zero the extruded length again
G1 F9000
; Put printing message on LCD screen
M117 Printing…
;Layer count: 100
;LAYER:0
M107
G0 F9000 X11.800 Y11.800 Z0.300
;TYPE:SKIRT
G1 F1200 X-11.800 Y11.800 E1.17741
G1 X-11.800 Y-11.800 E2.35482
G1 X11.800 Y-11.800 E3.53223
G1 X11.800 Y11.800 E4.70964
G0 F9000 X11.400 Y11.400
G1 F1200 X-11.400 Y11.400 E5.84713
G1 X-11.400 Y-11.400 E6.98463
G1 X11.400 Y-11.400 E8.12212
G1 X11.400 Y11.400 E9.25962
G0 F9000 X11.000 Y11.000
G1 F1200 X-11.000 Y11.000 E10.35721
G1 X-11.000 Y-11.000 E11.45479
G1 X11.000 Y-11.000 E12.55237
G1 X11.000 Y11.000 E13.64996
G0 F9000 X10.600 Y10.600
G1 F1200 X-10.600 Y10.600 E14.70763
G1 X-10.600 Y-10.600 E15.76530
G1 X10.600 Y-10.600 E16.82298
G1 X10.600 Y10.600 E17.88065
G0 F9000 X10.200 Y10.200
G1 F1200 X-10.200 Y10.200 E18.89841
G1 X-10.200 Y-10.200 E19.91617
G1 X10.200 Y-10.200 E20.93393
G1 X10.200 Y10.200 E21.95169
G0 F9000 X9.400 Y9.400
;TYPE:WALL-INNER
G1 F1200 X-9.400 Y9.400 E22.88962
G1 X-9.400 Y-9.400 E23.82756
G1 X9.400 Y-9.400 E24.76550
G1 X9.400 Y9.400 E25.70343
G0 F9000 X9.800 Y9.800


#7

Perhaps uncheck the “Printer center is zero” in your printer profile, save and re-slice.

This GCODE file assumes that the center of the bed is 0,0. However you say that the printer starts in one of the corners, which indicates that 0,0 is in THAT corner


#8

@Daniel

Ok I see, changing the slider setting means that all the ‘pre-setting’ gcode is basically invalid… didn’t think of that

I’m waiting for a few more upgrades to be delivered… my new hotbed buildplate is delayed… once I have that I’ll retry and update

Thanks for the help


#9

@Daniel

Just wanted to let you know that your suggestion worked!!.. deleting the sliced code, resetting the settings and then reslicing seems to have sorted my issue.

Thanks for the help