[SOLVED] AstroBox will not update software

Astrobox is at 10(8). Attempting to update gives an error (red bar appears on browser and says cannot connect). It also does not update to my new password here. I can click on the cloud on the box UI and it opens a browser and it says it is connected …

What do I need to do?

The 0.10(8) is affected by a bug in which the date on the device is not updated. This caused the SSL certificate on our server to seem invalid (because the box has a date prior to its issuance). This is easily fixed.

You need to access the box command line. There are two options:

  1. Connect an HDMI monitor and USB keyboard and reboot. You will see the command prompt on your monitor.
  2. SSH into your device (let me know if you need help with this).

Once you are at the command line run the following commands:

sudo su
service astrobox stop
echo '2017-09-15 00:00:00' > /etc/astrobox/last_known_time

After this, you can access your box again and perform the update. The 0.10(9) version fixes this.

Awesome! Thanks for this! I was just checking for updates when I encountered this issue.

NB: Previously the “new update” banner that would show on the Dashboard homepage did not show up either. After fixing and rebooting this banner immediately showed up. Update to 0.10(9) worked without an issue!

1 Like

April 2020 Update:

This still works. Update the date in the echo line to match your current date.

Thank you for the information Daniel.

1 Like

Can confirm this still works. Just used it today for an Astrobox that was offline for several months.

1 Like