[SOLVED] Astroprint Plugin issue on Octoprint (Astroprint box router is disconnected)

I have to Octopi setups connected to two ender 3s. The first I have had running for a while, I originally installed the Astropint plugin to test it out and really liked it. It eventually broke and I couldn’t see it in Astroprint cloud. I assumed that I installed something or changed a setting that broke it. Tried a couple of times to get it to work again, deleted some plugins and reset Astropint etc without any luck. Got a second printer so did a fresh install of octopi and Astroprint, hoped it would work perfectly however got the same result. Astroprint box router is disconnected! Frustrating to say the least, however, makes me think that the issue is network/router/isp related because it is happening to both printers. I have both wired, first one was originally wifi however while troubleshooting the Astropint plugin I ran ethernet to eliminate week wifi issues. Any help or suggestions would be appreciated.

Edit: decided to ping api.astropint.com and all pings failed. I then did a traceroute and on hop#11 it went to a ip and then it failed. The IP is a Comcast IP (does Astroprint host on Comcast?) it doesn’t make sense why it ends. I don’t know if Astroprint servers are blocking my printers or what is going on. As I said, any help would be appreciated.

AstroPrint does not host on Comcast. We use Amazon AWS. What seems to be happening is that your ISP has wrong DNS records perhaps.

There’s nothing wrong with our servers at the moment. 1000s of other astroboxes and OctoPrint instances are currently connected.

Yes, it is strange. I am going to have to try changing my DNS servers and see if that fixes the problem. It seems that my request is never leaving the Comcast/Xfinity network. So frustrating.

Problem solved, it was DNS routing me into a dead end. Switched to openDNS and now it works.

1 Like