(SOLVED) Cannot connect without Edimax dongle (Pi3 B)


#1

I set up a new Astrobox using a Pi3B and used the edimax dongle (connected to a Prusa MK3). Setup was a breeze, of course! I can find the Astrobox at 192.168.0.69 on my home network and I can access it via the cloud, as well. However, if I take out the Edimax dongle (I don’t need it in there anymore, right?), I lose all connections. If I try a local connection, I get nothing. If I try the cloud, it says no connected devices. Plug the Edimax back in, and I can see it again. It seems that the Pi is using the edimax dongle for the primary internet connection, not the built in Wifi chip.Also, I had a job running over nigh, with the Pi connected via the USB port. I woke up this morning and it had just stopped. I am blaming the Pi and Astroprint.

What did I do wrong?

EDIT: Since no one was able to offer any guidance, I continued my search for answers. I am still not sure why the setup would not allow me to remove the Edimax dongle, but I eventually found this link to get it properly set up using ethernet and Astroprint Desktop: https://astroprint.zendesk.com/hc/en-us/articles/360000337286-How-do-I-setup-AstroBox-Gateway-without-dongle-hotspot-


#2

Hi @Tom_Rueckl, sorry the forum runs a little slower over the weekend. The problem with the dongle is known since Raspbian updated their OS to Stretch it seems to link the network configuration to the HW interface and yes, in some cases the device picks the dongle as the primary WiFi instead of the internet. Which causes what you describe.

That is exactly the reason why we created the guide to set it up without the dongle and furthermore created the the AstroBox Touch so you can do it via the touchscreen.

Regarding your print failure, we also have an article about that here: https://astroprint.zendesk.com/hc/en-us/articles/115001797403-Why-does-my-printer-disconnect-in-the-middle-of-a-print- AstroPrint is not always at fault :wink:


#3

Thanks for the reply. Maybe I can bother you with an additional problem?

The Astrobox that I was setting up was for a friend. So, I got it all set up at my home, assuming it would be easy to switch to his wifi. Boy, was I wrong!

I took the astrobox to his house and connected it via ethernet to his router. I found it at 192.168.1.119 I used the web UI to scan for and connect to his wifi. I shut down, disconnected the ethernet, and then rebooted. I couldn’t find it. So, I downloaded the astroprint desktop, reconnected via ethernet, went to apps, printers and searched for the box. No luck. Couldn’t find the astrobox.

We have it working via ethernet, but that’s not convenient. Before I reflash the os and start over, I am hoping you have a solution.

Thanks.

TR


#4

It might be that the internet signal is low. You might also want to try to delete the connection you created before and try again.