[SOLVED] Hot end stays on model after print finishes

I am having a new problem that I didn’t used to get. Maybe it is since a recent firmware change? When my print completes, the x and y axis used to home so the nozzle moved away from the print, but not it just stays on the model where it finishes. How do I fix this because it is ruining everything I print.

We did some changes to the end g-code. If you go into your printer settings under advanced you may need to add some end g-code. If you need help with the settings to add let us know what 3d printer you have and we can give you a suggestion.

Josh. I have a RepRapPro Mendel and would appreciate your help with how I fix this.

Here is a basic end gcode. You can copy this and paste it in the end commands section of your printer profilte: to get there on astroprint.com go into printer profiles | click on the pencil icon of the printer you want to edit | click on advanced settings and this will show a space to add end commands | paste the code below into the text area and save your profile.

G28 X0 Y0 ; home X axis and y axis
M104 S0 ; kill extruder temperature
M140 S0 ; kill bed temperature
M84 ; disable motors

I know this is an old post, but thanks Josh; This was clogging my nozzle, making follow-up prints a huge pain, not to mention brewing anxiety as the end of a print finished, as I was having to babysit it and manually move the X axis.

1 Like

Hi there,
I’m new to the astroprint community and would like to know, if this end gcode command only works when you slice the models with your cloud service. I generate my gcode with kisslicer and would like to keep it that way. The prints I’ve done through local print suffer from the same problem like rammy described. I’ve put the following gcode in the end command of the online settings:

G91 ; Make coordinates relative
G92 E0 ; reset Extruder counter
G1 E-10 F2000 ; Retract extuder 2mm at 900mm/min
G1 Z2 F400 ; Move up tw mm (from current position because it is all relative now)
G1 Z2 F5000 ; Move Z another 2mm up
G90 ; Use absolute coordinates again
G1 X5 Y5 F3000.0 ; go to almost home
M84 ; disable steppers so they dont get hot during idling…
M107 ; Turn off fan
M104 S0 ; Turn off heater of extruder
M140 S0 ; Turn off bed heater
M117 Print Complete

But when printed locally the extruder just stops on top of the print after finishing.
Is there a way to fix that problem?

Thank you very much!
greetings from germany

Hi there. The code that Josh gave above fixed my problem. I see that you don’t have the G28 code in yours, so maybe you should insert that and give it a try?


I have an Anet 8 printer, what end code should I use to make it home all axis when finished?

I have fixed this for the Anet A8 profile on the AstroPrint Slicer by adding G28 X0 Y0 to the End GCode.

I have the same issue and need the end gcode
for Geeetech a10 please and thank you :grin: