[SOLVED] Online slicer starting script issues


#1

Maybe I am doing this wrong but I do not think I am lol.

I am trying to get Dagoma Neva set up working, and am using Cura for the slicer in the slicer options and have the following slicer start gcode:

G90
G28
M109 S100
G29
M104 S{material_print_temperature_layer_0}
G0 X0 Y-85
G0 Z0.26
M109 S{material_print_temperature_layer_0}
M82
G92 E0
G1 F200 E6
G92 E0
G1 F200 E-3.5
G0 Z0.15
G0 X10
G0 Z3
G1 F6000

When I run this what happens is it will just grab the s100 command and ignore the rest. So it stays at 100 and never changes. If I manually change the lines M104 S{material_print_temperature_layer_0}, and M109 S{material_print_temperature_layer_0} to a temperature it works find, and changes the temp just fine. Why doesn’t this command work like it should??? I need to be able to run the calibration codes with the head at a non printing temp to avoid oozing, and then go up to printing temp, how do I do this??


#2

So now it seems like sometimes it completely ignores the start code entirely. I just kicked off another test print with a custom slicer setting and set the filament temp to 200, and this time instead of starting at 100 and then going through the g29 and then waiting and going to the 195 temp it just went directly to 200… wth!!!


#3

Ok I have done multiple test prints now, and it is completely ignoring the first temo command and just going to the temp command I entered into the custom slicer settings for the temp field. I am not sure why the start code doesn’t get run first…


#4

Sure enough when I look at the file after slicing it puts the VERY FIRST line of code M109 s(whatever the slicer temp setting was) whats the deal with that??)


#5

Jeffrey, where did you find that start code. The variables are wrong. They might now be for the version of Cura that we have. Can you try this for the M104 and M109 lines:

M104 S{print_temperature}
....
M109 S{print_bed_temperature}

#6

That still doesn’t work. Here is the current start gcode, and all it does it heat up to 100, run through the calibration, then start printing at 100 degrees.

G90 ;absolute positioning
G28
M109 S100
G29
M104 S{print_temperature}
G0 X0 Y-85
G0 Z0.26
M109 S{print_bed_temperature}
M82 ;set extruder to absolute mode
G92 E0 ;zero the extruded length
G1 F200 E6 ;extrude 10mm of feed stock
G92 E0 ;zero the extruded length again
G1 F200 E-3.5
G0 Z0.15
G0 X10
G0 Z3
G1 F6000


#7

Gah, this is driving me crazy, all I want, no I really NEED is for the dang thing to do the calibration at a tempature LOWER than the melting point of the filament, then go to the front of the bed, and wait for it to heat up to the print temp, and then print. It is causing a huge mess, and making for bad calibration because the oozing of the plastic making the offset wrong.

:frowning:


#8

On a second look i noticed a typo in the advice I gave before. Here’s a new GCODE sequence with some comments explaining what’s it does:

G90 ;absolute positioning
G28
M104 S100 ;start extruder heatup, no wait, max 100
M140 S{print_bed_temperature} ;start bed heatup, no wait
G29 ;do calibration
M109 S{print_temperature} ;continue heating and wait to reach temp
G0 X0 Y-85
G0 Z0.26
M190 S{print_bed_temperature} ;wait to reach bed temp
M82 ;set extruder to absolute mode
G92 E0 ;zero the extruded length
G1 F200 E6 ;extrude 10mm of feed stock
G92 E0 ;zero the extruded length again
G1 F200 E-3.5
G0 Z0.15
G0 X10
G0 Z3
G1 F6000


#9

This works perfectly!!! Thank you!!!