[SOLVED] Printer stopped being recognized


#1

Hello everyone!
I have a Tevo Black Widow and a RPi astrobox.
I was able to connect to the printer normally and even printed via astroprint already.
2 days ago, I’ve turned everything on and start heating my printer via astrobox, but suddently it stopped working.
I was getting a “connected” followed by printer unplugged" status repeatedly, then finally it stopped being recognized.
I’m running out of ideas on how to troubleshoot this and already searched by similar issues before opening the topic but found nothing.
Anyone could help me on that?
Astrobox is working and connected to the internet.

One thing that worth mentioning is that everytime I’ve shutted the box off, it was directly cutting the power because everytime I have tried the shutoff icon, it returned “there was an error starting shut off sequence”.

Thanks in advance.


#2

Managed to get it working for a few minutes yesterday by connecting printer to astrobox via a shielded and short cable, but the overall behavior is the same: it works for a bit (minutes or even seconds) and then the connection breaks.
I don’t think it’s interference on the usb right now. My only guess is that the power supply have too much noise of some kind (I can actually even hear it).
Or can this issue be Marlin related? I’m on stock Marlin 1.1.0 rc7 that came with the printer.


#3

Got it working!
It was in fact a hardware issue. Solved it by routing the usb cable away from the others, adding a ferrite bead to it and reflowing all the usb related components on the MKS GEN 1.4. It’s now working 100%!

Moderator can lock the thread an mark it as solved.

Thanks for the help.


closed #4