[SOLVED] Printer stops mid print


#1

OK so my printer keeps stopping in mid print. From what I can tell is that the Astro box loses its connection to the printer and reconnects thus causing The printer to restart and stop the print. I have no idea why it’s doing this. I am using a Prusa i3 with a pi b+. I’m using a Kodak S101 web camera. My astroprint software is 9.2


#2

I saw the logs you sent but there was no useful info there. If the problem is comms with the printer you would need to enable serial logs, have it happen again and resend.


#3

okay, i will do this. thanks for the quick response:)


#4

i just tried printing again but this time it worked fine. Could be that i upgraded my camera… Maybe? i dont know. But if it happens again ill let you know.


#5

Have you tried to change the usb cable? I had the same issue and, for me, the problem was caused by the poor connection between the printer mcu and the astrobox.


#6

Did you have any luck on this one? I have two 12" printers with an astro each. One has no problems at all, the other has paused/stopped my print twice now. Its really frustrating when you find a 48hr print stopped at 97%… I will try changing my USB, but the existing one is brand-new! I will post my results.


#7

Did you find a solution? this sounds similar to a problem I’ve been having…


#8

The problem was traced down to a insufficient power. For a RPI2 we recommend a 2.5A power supply


#9

I’m using a pi3b with a 2.5a supply


#10

I had problems previously with the power supply, and the printer would stop and the temperatures would drop to zero for the extruder and bed, when I logged back in I got a warning that my device was not properly shut down. This new failure doesn’t give me the bad shutdown warning, and leaves the extruder and bed at printing temperatures.


#11

Just started using Astroprint and getting the same issue. I have a Rpi3 with a branded Rpi PSU and using a PS Eye camera. Printer runs for a 1 layer then stops. A pause/resume restarts it but only for half a later or so then it does it again. Any ideas appreciated.

Damian


#12

Please take a look at this and if nothing works send us serial logs (as explained there): https://astroprint.zendesk.com/hc/en-us/articles/115001797403-Why-does-my-printer-disconnect-in-the-middle-of-a-print-


#13

All working now - replaced the PSU. THe origional was for my pi1 and only 1a