[SOLVED] Unable to update due to internal storage


I’m trying to update to the latest version [0.18(0) published 22 April 2020 from the version currently installed [0.17(4)], but I’m getting the red bar at the top saying “Available internal storage is below 1 GB”. This is a brand new installation and I have deleted the 1 gcode file I had on there.

Looking at a partition manager, I have 2 partitions on the SD card (boot [198mb free] and rootfs [12.9gb free]). Do I have to resize the boot partition to add more storage? Is this the normal upgrade procedure?

Please assist.


No, somehow the device is detecting you have more in your card. What do you see when you go to the storage area in settings in your astrobox web UI?

Hi Daniel


This does not match up with what I’m seeing in the partition manager when I plug the SD card into my PC.

What do you see in your partition manager? Maybe you have more than two partitions? What does this command output:

df -h

The partition manager (AOMEI) that I use shows this:

df -h shows this:

This is consistent with what our system sees. Even though the card has more space, the system isn’t able to use it.

I think you can execute raspi-config and select the expand filesystem option, then reboot

Thank you! That has solved the issue! :slight_smile:

1 Like