[SOLVED] Wrong layer height on Slic3r


#1

For some reason as of yesterday, every slice I make using Slic3r is resulting in GCODE that has a layer height of .07mm hardcoded, completely ignoring any layer height settings in the slicer profiles. Is it possible that the software on the cloud server crashed, and just needs a reboot of sorts?

I have an Anet A8, haven’t had any such issues with Slic3r up until yesterday, no settings changed. I even tried creating duplicate printer profiles with factory settings, no luck. Material profiles and slicer settings don’t make a difference either. I tried fresh material profiles with the stock slicer settings.

Cura for some reason doesn’t treat my printer well, so I have to rely on Slic3r to get the job done. With this new issue, I’m completely unable to print anything new. Old slices work just fine as well, in case that makes a difference, so the rest of the software/hardware works with no issue.

Thanks for all you folks do.


#2

We did upgrade slic3r a few days ago. This is weird… What about other settings, do they work?


#3

Any slicer settings, material profiles, and any printer profiles using the Anet A8 as a base all result in the issue.

Strangely enough, I did try adding a completely different printer profile for a printer I don’t own, just to see if there’d be a difference. (MakerBot Replicator 2x) That did result in the correct layer height, but I didn’t want to try to use that one because of the physical printer differences.

I did manage to download Slic3r onto my PC as a workaround for the time being, and that does work correctly for all the configuration copied over from the values I had set on Astroprint. The version I downloaded is 1.3.1-dev if that helps. I noticed that this version isn’t the Prusa Edition, so I’m not sure if that would make the difference.

Since I have the workaround for the time being, it’s not a mission critical issue anymore fortunately, but I’m not sure if others would be running into the same issue, as the A8 seems to be a popular printer these days. I definitely like Slic3r over Cura personally, but that’s just me :smile:


#4

@robotdanb can you try now? I think we have found and fixed the problem.


#5

Indeed, that did the trick. Much appreciated for all you folks do. Out of curiosity, what ended up being the issue? Did Slic3r update the variable name or something and have a default of .07 if not present otherwise?


#6

The new slic3r version has to do a second pass at processing settings. Here’s the comment in one of their perl files:

# Do the apply_config once again to validate the layer height profiles at all the newly added PrintObjects.

Without this it was ignoring the setting layer_height and using the value set for min_layer_height which is set at 0.07 by default.


#7

Interesting. I had figured it was something like that.

Odd new issue I noticed last night, is it possible the same issue may be affecting infil percentage as well? I sliced at 20% infill, but the resulting print appears to be in the range of 35-50% infill. I didn’t notice until partially through the print, so I’m just letting that one finish as is, but I figured I’d double check on that as well.

Thanks again. :slight_smile: