Steppers Disabling at end of print


#1

HI guys. I am having a problem at the end of a print where my Z falls and hits the build plate.
This is my custom end gcode.

G1 Z25 F400
M107; Turn spindle off
G1 X0 Y0 Z20 F2000
M84 S1800 ;Change Stepper disable timeout to 30 minutes.

Yes I know thats not a normal end Gcode I am using it on a CNC machine. it has been working perfect until now… I change two things. I updated my marlin on the ramps board and updated the astrobox at the same time. just trying to trouble shoot.

If I print with pronterface it holds the steppers after the print…
but when I print with my astrobox the at the end of my print the Z falls.
Does the astrobox add anything to the end gode. I am not using astroprint to slice just to print/control…


#2

Is there a disable stepper G code command in the end of print gcode area in the printer profile? If so maybe this is overriding the file end gcode.


#3

As an example, the profile printer settings for my creator pro (not a delta I know but just an example).


#4

Hi Neil.

I don’t have that option in my printer profile


#5

I just did a print while watching the gcode. astrobox is adding M106 S0. but nothing about disabling the steppers.


#6

Did you slice using Astroprint or just upload the Gcode?


#7

Just uploaded the gcode…


#8

Ah right, in which case the printer profile end code would not be relevant. Sorry, I’m out of ideas then.