Unable to update


#1

I’m trying to update my Astrobox from 0.5(2) to 0.5(3), but I keep getting an error saying that it is unable to update. I watch the progress bar, and it goes from Download -> Install software -> Checking software -> Upgrade Software, and then I get the “System Update Failed” error.

Is this due to the fact that my printer is not plugged into my Astrobox? (I can’t plug it in now because I’m busy with a 4 hour print, and only halfway)


#2

I am also having problems updating to 0.5(3).
I never get beyond “Installing Dependencies. This might take a while…”
I included image of screen.

Peter


#3

I had the same issue. I overcame it by SSHing in, apt-get update/upgrade and then it didnt hang on the dependencies.


#4

So after trying things, I am still unable to upgrade. However things seem to be better than before…

I followed cameron’s advise and logged in with ubuntu/astroprint (changed the password while I was there) and ran
/> sudo apt-get update
and then followed that with a
/> sudo apt-get upgrade.
This got me to a point where it was hanging on installing dependencies, so I did a
/> sudo reboot.
Now I was able to get passed the dependencies, but I still can’t update.
I tried running the
/> sudo apt-get upgrade
again, and noticed that I got errors from 2 packages, namely:

  • bind9
  • nscd
    See the screenshot for the errors.

So… any new advise that I can try?


#5

Thank you cameron.

I did what you said.
However, I had an issue on the apt-get upgrade with space.
So I tried the Upgrade Software option on the Astro Box again and this time it ran fine.
Not sure if the apt-get update/upgrade did the trick or if the Astro Print people did something…

Peter


#6

Guys sorry but we have some problems with auto upgrade in this release. The easiest thing is to get the release from the downloads page and reflash your SD cards

BTW, doing apt-get upgrade is not recommended. Some RPi packages updates the kernel and our wifi driver will stop working.


#7

Once again thank you Daniel for you support.
It is sincerely appreciated.

Peter


#8

Not sure if that applies to me as well, because I have the pcDuino v2 board…

Also, should I again create both SD cards (Ubuntu Kernel and AstroBox card)? Or do I just need to create the Astrobox card?


#9

Updated manually. Working now. :smile:


#10

Pcduino should update without problem… Also doing apt-get upgrade has never updated the kernel for me


#11

Clearly it didn’t work for me, but it is sorted now. I hope the next update will work without a hitch.


#12

The screenshot you sent indicated that the /var/lib/update.rc didn’t exist. What did you do to fix it? Also what version was on the device before you attempted the update?


#13

As per your advise, I …


#14

Sorry for asking questions that were answered I the thread. Too many open threads…

When you say manually, did you mean you reflashed? That’s ok but I was giving that advice to RPi users.

However it seems that your upgrade failed too so what you did is probably the best way.

I believe that the missing /var/lib/update.rc directory is the reason why it failed. I don’t yet know if the RPis are failing for the same reason or why it was missing at all.


#15

Yes, I downloaded the image files and reflashed.


#16

So it turns out that the problem with updating from 0.5(2) to 0.5(3) has to do with outdated package source urls :frowning:

The solution is to run the following command before attempting to upgrade (just like @Skylinc mentioned):

sudo apt-get update 

However be careful NOT to run apt-get upgrade. At least on the Raspberry Pi or you’ll lose the WiFi drivers as they have updated their kernel version.

All of this should be sorted out by our software in the next release.


#17

Daniels advice is sound. I am using a supported wifi usb modules from this list like i run on all of my pis http://elinux.org/RPi_USB_Wi-Fi_Adapters. All of them run a different flavor of linux. I however do not see why you would say upgrading isnt recommended. In the Iot age, consistent upgrades reduce the risks of security issues. Id rather loose my wifi than have someone compromise my network because gcalculator wasnt updated. Again this is just my example but my printer and other 2 pis auto update every other day and i have no issues with my edimax module failing. Granted on 1 of them runs astroprint. My build has farrrrrr more cruft removed than the stock image. I dont need minecraft-pi on my 3d printer, just saying.


#18

I agree that the system should be kept current and we don’t let it go too old. The problem is that the stock wifi driver doesn’t support concurrent wifi device mode.

We need to recompile the driver for things to work well with our UI. It’s probably not a problem for advanced users that can configure the network themselves it very useful for those that use our setup wizard to setup their network.

Regarding cruft, what packages do you recommend removing? I’d love to reduce the size of the image more too.


#19

I have removed soo much already, I will need to fetch a new image and get a dkpg list. For the sake of staying on topic we can start a new thread or pm.