Update fails then I get that root user is locked


#1

Hi,

I just started my AstroPrint touch box and got a message that it is a new update available.
I let it start the update and around 12% of the update it stopped with the error message:

  • Internal error, wait we reconnect.

It did not do anything so I powered off and on.
When it restarted I got the following error msg:

  • Cannot access to console, the root account is locked

I followed a tip on adding to the commandline.txt file the following:

  • init=/bin/sh

Even so, it seems now it doesn’t boots at all. Is dead.

Question:
If I re-flash the sd card do I need another serial number for the software?

Thank you,
Alex


#2

Yes, modifying any of the system files is definitely not recommended. It’s hard to know what happened to your box without further inspection and it does seem like now our only option is reflash.

Open your SD Card in a computer, note the contents of the file at .astrobox/lid. Then open a ticket with us with that information and we will follow up on how to re-flash your device.

https://astroprint.zendesk.com


#3

Hi Daniel,

I did not modify any system files.
It simply crashed in the update step and from there I got into this second error with the root user locked.
I will raise ticket now.

Thank you,
Alex


#4

I was referring to this.

It’s no problem though. I just wanted to note it here that is always better to contact us before trying these types of things. In most cases we can resolve the issue without re-flashing and it also helps us learn of possible failure points to make the product more robust.


#5

Hi Daniel,

Thanks a lot for your prompt help.
I would like to mention something related to the update process:

  • During the update I guess some processes are shutdown by the update script.
  • Because of this an internal error is displayed. But this goes away after 10-20 seconds or so.
  • However this kind of error panicked me and I powered off the box and from there I run into the root user locked issue

So my suggestion would be that you guys do not display unnecessary error messages to the user, unless is a fatal one. It is not necessary. It creates confusion.

One more question:

  • I ran (after re-flashing my sd card) the update on your software. It completed successfully but it stays on displaying 100% completed and is not rebooting or at least displays the UI.
  • I have a bad feeling about this, because if I power off I may run into the same issue as I had with root user locked.

Please advise on this situation described above.

All the best,
Alex


#6

The error is necessary. It shouldn’t happen. If the UI layer can’t communicate with the underlaying AstroBox Service, you won’t be able to see any progress updates. I don’t know why the service went away ( it shouldn’t ) but when it does go away, we need to tell the user because a LOT of things won’t work.

Did you use the image that I sent you in the ticket instead of the one in the original email? The reason I ask this is because that image had the latest software available and you shouldn’t see any updates available right now.


#8

If you were updating and due to some technical issue if it stopped and then you are getting the error that itunes customer care the user is locked then you have to delete the update file and once again try to update