Update to 0.19(3) Bricked my Astrobox when using X3G Driver

Just autoupdated, after login it gave me a:


Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

So i reinstalled from scratch.
After the initial configuration… got the same error.

It was working since 2017… till now…
Is there any solution? Rollback maybe?

After a quick email exchange with the customer care, they’re really fast indeed, we solved the problem, it was the X3G driver.

Waiting for an emergency patch today.

Great service, I’m really amazed.

Same story here on my two RPi Astroboxes. Did they indicate what it would take to install the patch, given the lack of access to the box?

The new software 0.19(4) is now available for download. Just reinstall from scratch. It’s the easiest way.
I don’t know if there is a way to patch instead, because when I had the problem I’ve formatted the SD and start anew.

This error has now been corrected with a new image version 0.19(4). You can re-flash your boxes with the image in our downloads page if you have a self mande AstroBox Gateway. If you have a purchased ABG or AstroBox Touch, please get in touch via support tickets for steps BEFORE re-flashing to avoid loosing your license.