Upload from slicer directly?


#1

I’m using the AB Touch software on my Pi and after unlocking SSH I was able to get Simplify3D to upload files directly to the /AstroBoxFiles/Uploads folder whenever I export the gcode. However this has recently stopped working properly (I believe the Uploads directory doesn’t get scanned until you upload something from the GUI so new files don’t appear).

I know it was a workaround and not supported so I’m not asking for help with that, however is there a possibility that something like this could become a feature? Like an API in the software (rather than the cloud) that enables direct transfers from the slicer? It was so nice when it worked, just hit “export”, walk to the printer/AB, touch print, internal, filename and print away! Either that or just monitor the Uploads directory for changes??

Thanks for the awesome software

edit : I just thought of another way this might work, albeit a little trickier - if I share a directory on my Windows box and mount it on the Pi using Samba/CIFS in place of /AstroBoxFiles/Uploads is there any way to make the software pick up new files immediately? Like a forced rescan of the Internal files?


#2

Like you said, this isn’t supported but If it was working and it stopped we might have inadvertently removed it. I wasn’t intentional. Do you remember when this stopped working (which version was the last one that worked?)

In any case, we’re planning a feature by which we will listen to a folder in your PC ( when the AstroPrint Desktop App is installed ) and upload gcode files to your cloud account. Once there you can print from the touch or the cloud itself.


#3

It would’ve been within the last few months, but I don’t know a version number where it stopped. I verified that the new files still appear in the Uploads folder after the SCP and they appear if I upload something else to that folder through the GUI, so it’s just that it’s not rescanning even if I switch between Internal/Cloud/External.

I like the idea of the Desktop app monitoring a folder though, then you could just go to “cloud” on the Touch to see the list. Thanks!


#4

Tested again and it DOES still seem to be working, but the files appear randomly in the “internal” screen (there’s no sort order) and it doesn’t have the Layer count when printing, only the estimated time left.


#5

They’re sorted by last printed ( in case you’d like to re-print ). It’s possible that the analyzer didn’t finish or it couldn’t figure out the layers. After first print, it should update that.