Webcam still-pics work, but streaming video doesn't


#1

I recently set up Astrobox Gateway on a Raspberry Pi 3 Model B following the directions here: https://blog.astroprint.com/how-to-create-an-astrobox-with-a-raspberry-pi-3/. It seems to work, although I haven’t received my 3D printer yet (Prusa MK3).

Today I connected a Logitech C920 webcam to test it out. I can take and display still pics fine, but when I try to turn on video streaming, I get this error message: “Oops! There is currently an error with Streaming Video. A few things to try: Check the connection from your AstroBox to your camera, reboot your AstroBox, or return to your Dashboard and try again later.”

The connection is fine, I’ve rebooted several times and have come back later, but still no go. Anything I should check out? Is it necessary to have a 3D printer attached to make the video streaming work?


Webrtc support?
#2

What browser/device are you trying to see video from?


#3

This was under Safari 11.0.2 on a MacBook Pro running macOS High Sierra 10.13.2.

However, I also tried Firefox and Chrome on the same MacBook, and video streaming works fine with both of them. I can use one of them for the time being.


#4

Yes, Safari did work in version 11.0 but then stopped. I think Apple is still figuring out WebRTC.


#5

Hello,

I have the same problem but I’m using android app and Opera browser.


#6

Opera browser isn’t supported. We test on chrome, Firefox and safari.


#7

I am having the same issue with Firefox (57.0.4 - 64-bit). I can take still images, but no streaming. This stopped working about a week ago. I have Astrobox on a pi 3B that is up-to-date both on the pi and astrobox side.

Any help would be appreciated.

Thanks, Dennis


#8

Same issues I’m using chrome and Mozilla can’t get streaming with my c920


#9

Are you on an Android device?


#10

Has there been any resolution regarding this?

I am on a Mac (macOS 10.13.3) running Firefox 58.0.2 (64-bit), webrtc stream used to work fine… then stopped. Camera still works for stills and is properly detected.


#11

Software is up to date, v0.10(11)


#12

HI. Same issue.
windows 10, up to date. tried chrome and explorer.
same hardware as the poster above too.
just updated the astrobox itself on 2018-06-12.
any help offered?


#13

I am getting the same issue. I can do pictures and time-lapses, but streaming throws up an error message.

The weird thing is streaming works when I go to the astroprint Cloud site and open Monitor.
The error is only when I connect to my Pi 3 directly.

I tested this on a Windows PC with Chrome and Edge browsers, as well as the Android app.


#14

Here is a weird thing…I can stream video via the AstroPrint web interface…but I get an error that it can’t start RTC when I connect direct to the astrobox local controls.