Astroprint says fils is not compatible with mk3s

I recently plugged an Astrobox (self-made) to my Prusa mk3s but I’m having an issue.

The only available models to pick were mk2 and mk3, so I picked mk3 despite having an mk3s.

Now I’m getting a warning whenever I want to print, saying the gcode is not compatible with my printer.

How can I get rid of the warning?

The sliced file and the astrobox need to have the same model to avoid the warning.

I know, but the Astrobox doesn’t know the mk3s so I had to configure it as an mk3.

How can I tell Astrobox that mk3s is an actual Prusa model?

I see, you created the mk3s as a custom profile. In that case, simply remove the printer model from the astrobox profile settings.

No, I didn’t create the mk3s as a custom profile. My slicer (PrusaSlicer) creates gcode with “mk3s” as printer model, but Astroprint doesn’t know about mk3s so my printer is using the mk3 profile.

But I guess creating a custom profile could solve my problem? That said, considering the mk3s is an actual printer (and regular mk3 are no longer sold by Prusa) shouldn’t Astroprint have mk3s in the list of printers to pick from?

Sure we will add that printer at some point. There are 100s of printer models out there and we have a process to add a new one.

So your GCODE is generated outside the platform. The best thing to do for your is to go into your astrobox settings and remove the printer model from the profile.

We have also added the mk3s profile now