Astroprint wont connect to printer, but Octoprint does


#1

Have a Tevo Tornado and a RPI3. Octoprint connects but Astropi never finds it on the USB.

Here’s the log of Octoprint connecting:

Changing monitoring state from ‘Offline’ to ‘Detecting serial port’Serial port list: [’/dev/ttyUSB0’]Connecting to: /dev/ttyUSB0Changing monitoring state from ‘Detecting serial port’ to ‘Opening serial port’Connected to: Serial<id=0x6ce15d50, open=True>(port=’/dev/ttyUSB0’, baudrate=115200, bytesize=8, parity=‘N’, stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitorStarting baud rate detectionChanging monitoring state from ‘Opening serial port’ to 'Detecting baudrate’Trying baudrate: 115200Send: N0 M110 N0125Recv: �2�[2\x03�\x0c�� \x192Z “\x1b4\x04�D\x06�6\x04�\x014Z%�y���@�\x01D��P\x0b���U\x05d��U��\x05Q$���; k�\x03%M�\x12�UP���y\x00H\x00\x07���T�\x00�\x10\x037���[��S��hf�\x01��\x02y\x00D���K\x01J\x04\x08\x15+� \x06WPy\x00E��\x1b��\x03��\x01\x11B�^����”\x1b�Y���\x00�\x01\x12F�"��D}\x12�\x15)�����\x03v��a^ \x11�"\x04�"\x04\x11�\x11DX����\x03��M 2�^�\x1b4M��m2�}�mZ\x01J\x04\x11$\x04�\x11DD��\x12$�\x05�I\x10�m2�@�\x13�m\x12�@�Y���\x03\x1bv��\x033>�������\x00�\x10B@F�"D��D��D"D)D����U���\x01J\x06\x12\x04�D"DZ ����\x06\x12�nh�\x00E\x10�"�\x04\x08\x00E\x10�\x12�\x11���\x12�M���\x00�\x01"�H����^ \x11�\x11FRecv: ~&\x0b�����\x15(&W�Baudrate test retry: 4Send: N0 M110 N0125Baudrate test retry: 3Send: N0 M110 N0125Baudrate test retry: 2Send: N0 M110 N0125Baudrate test retry: 1Send: N0 M110 N0125Baudrate test retry: 0Send: N0 M110 N0125Trying baudrate: 250000Send: N0 M110 N0125Recv: echo:Unknown command: "\x18"Recv: okChanging monitoring state from ‘Detecting baudrate’ to 'Operational’Send: N0 M110 N0125Recv: okSend: N1 M11539Recv: okSend: N2 M21*18Recv: FIRMWARE_NAME:Marlin TORNADO (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:TEVO Tornado EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ffRecv: Cap:EEPROM:1Recv: Cap:AUTOREPORT_TEMP:1Recv: Cap:PROGRESS:0Recv: Cap:PRINT_JOB:1Recv: Cap:AUTOLEVEL:0Recv: Cap:Z_PROBE:0Recv: Cap:LEVELING_DATA:0Recv: Cap:SOFTWARE_POWER:0Recv: Cap:TOGGLE_LIGHTS:0Recv: Cap:CASE_LIGHT_BRIGHTNESS:0Recv: Cap:EMERGENCY_PARSER:0Recv: okSend: M155 S2Recv: echo:SD card okRecv: okSend: M20Recv: okRecv: Begin file listRecv: PI_CHI~1.GCO 1652337Recv: EFRAIN~2.GCO 7262102Recv: 3X_GOB~1.GCO 1020001Recv: TEVO_K~1.GCO 10316678Recv: ZP1_HI~1.GCO 3252643Recv: EFRAIN~1.GCO 283045Recv: 3D_PRI~1.GCO 2694437Recv: 50PCT-~1.GCO 28464111Recv: End file listRecv: okRecv: T:19.53 /0.00 B:19.88 /0.00 @:0 B@:0Recv: T:19.73 /0.00 B:20.04 /0.00 @:0 B@:0Recv: T:19.53 /0.00 B:19.80 /0.00 @:0 B@:0Recv: T:19.45 /0.00 B:19.88 /0.00 @:0 B@:0Recv: T:19.49 /0.00 B:19.77 /0.00 @:0 B@:0Recv: T:19.30 /0.00 B:19.77 /0.00 @:0 B@:0Recv: T:19.53 /0.00 B:19.92 /0.00 @:0 B@:0Recv: T:19.77 /0.00 B:20.08 /0.00 @:0 B@:0Send: G91Send: G1 Z10 F200Recv: ok


#2

Are you using the existing Tevo Tornado profile on AstroPrint?


#3

What baud rate do you use in AstroBox?