Flashforge Creator Pro Dual Nozzle Selection


#1

Hi Daniel, Dilanka,

I was wondering if there is an update on the dual extruder nozzle selection.

The Flashforge Creator Pro has a fan mounted next to the left extruder nozzle for the extra cooling needed when printing PLA.
Unfortunately the astro system does to allow selection of the left nozzle and I would need it so I can print PLA with the left nozzle and the extra fan.
Do you guys think you will add this functionality in the near future ?
It would be great if you would !!!


#2

@dssp: We understand the importance of this feature (which is a must) – but due to time constraints and priority levels in our development roadmap, this will have to wait until we ship a couple of critical updates.

I don’t have an ETA.

Believe me, I understand your frustration as I have a Flashforge Creator Pro sitting next to me and I am having the same issues :confused:

Stay tuned though! :slight_smile:


#3

Hi Dilanka,

Thanks for replying.

Looking forward see this feature coming out soon.

Thanks for your guys effort.

D.


#4

Yeah, I am having the same issue Creator Pro has no left dual extruder option and was wondering the same thing when? Hope you are able to fix this soon. I also have a Rostock Max v2 but it has the option to use both extruders although I only have one extruder on that printer and have not added a second one as of yet.


#5

Hello,

Any ETA when we may see this capability? Trying to keep from going back to Octoprint. :slight_smile:

Thanks!


#6

Not yet my friend! Finishing up a few other features/updates for our next release, then we will consider the dual Extruder issues :slightly_smiling_face:


#7

You can try to add T1 or T0 on the start gcode on your astroprint.com printer profile. Have you tried that? This will not be a solution long term but temporary.


#8

@Daniel Unfortunately adding T1 or T0 to the start gcode does not work, or hasn’t for me. I’m interested in swapping extruders. By the way, what a rocking product! I wish you had a pay subscription model, I know I’d pay to help bring more features forward!


#9

I’ve seen this topic go back well over a year in other threads as well… is there ANY progress on this at all?


#10

This must be a printer or rather firmware related issue…I use Repetier firmware and have a dual extruder printer. While support for using two extruders is limited for now in Astroprint I have had no issue either selecting the second extruder from my printer controls or by placing the T1, T0 commands into the start codes…For me AstroPrint seems to just assume what ever the current extruder that is selected is the one it will use…

My understanding might be flawed but I think the AstroBox just relays G-code to the printer…The only thing it seems to add is the code set in the Cancel Code in the printer setup on the astrobox itself if the print is canceled.

When it comes to Slicing start and end code are used by the cloud slicer based on the method of the individual slicer which are slightly different Cura vs Slic3r…adding the T commands an most other seems to work as expected.

I was a bit put off too when it seemed that AstroPrint could not deal with dual extruders but what I have found is that the Interface is weak when directly controlling the dual extrusion printer the slicers support it pretty much the way the do as stand alone apps, and when on occasion the cloud interface is limiting using the stand alone version of the slicer and uploading to astrobox seems to work okay.

Here is hope for full support in AstroPrint of all slicer and printer features like dual extrusion, bed placement, fan control, and all the others that the Astrprint guys are working on and Thanks for all the benefits we users already to enjoy for next to no cost.


#11

We just ordered a FF Creator Pro in our engineering. We’ll be looking at this shortly


#12

Don’t get me wrong, if I slice with SF3D and upload the file I have no issue printing at all. The issue is that there is only one nozzle control in the software so it always shows heating if I use only the left nozzle. It also doesn’t show the progress of the print. Just heating. So remote functions just don’t work.


#13

Have you solve left nozzle selection?
I have error in test connection with Flashforge Creator Pro…
I select Replicator 1…


#14

Chris, I have the same problem. I’ve noticed if I set a low temperature threshold on the unused nozzle, and the AstroPrint can see that the FFCP heats to that temperature, it will transition from the Heating screen to the normal print screen.

Hoping that this gets worked out someday. I love the software. It’s awesome to be able to print headless w/o an SD card! :smiley:


#15

wow I never even thought of that! How low can you go on Tool 0 for it to recognize it’s on and make it work?


#16

I made a video showing how to work around it. Hopefully it’s helpful!


#17

that’s awesome! Thanks for posting that!!


#18

I wonder if it would make it even easier to set up my profiles in SF3D to heat up tool0 for a couple layers then shut it down

I have a print I"m about to start, I’m gonna try it and report back


#19

Yep, no problem. You can try to set the unused tool back to 0 after, but it sometimes takes a few tries, just like setting the temperature.


#20

OK so that worked. I set my right nozzle to 70 for layer 1, then 5 from layer 2 on. Been printing for an hour now and still reading properly.